cancel
Showing results for 
Search instead for 
Did you mean: 

apache problem

SOLVED
Go to solution
rajesh73
Super Advisor

apache problem

I have RHEL enterprises 3 with apache2.0

1)i want to open one particular folder through access web browser

2) i configured in httpd.conf

Options FollowSymLinks

AllowOverride None

AuthType Basic
AuthName "Restricted Files"
AuthUserFile /usr/local/apache/passwd/passwords
Require user test

3) if iam opening http://localhost/test2
it asking username passwd (if i am entered wrong passwd it is saying wrong user name & passwd)
4) once i enterd the user name passwd correct it is accpeting
After that it is showing

Forbidden
You don't have permission to access /test2/ on this server.

pls any one help me sorry for the poor english
5 REPLIES
Ivan Ferreira
Honored Contributor
Solution

Re: apache problem

Try adding Indexes to your options:

Options FollowSymLinks Indexes
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
Steven E. Protter
Exalted Contributor

Re: apache problem

Shalom,

Missing information to solve this.

What is the root directory of the server in httpd.conf Perhaps post the whole file.

What does the .htaccess file say on this directory.

Permission from the OS on test2 can impact this problem.

What does the access_log and error_log say when you try and access?

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Matt Palmer_2
Respected Contributor

Re: apache problem

Hi,

have u tried setting AllowOverride None to AllowOverride AuthConfig?

HTH

regards

Matt
B. Hulst
Trusted Contributor

Re: apache problem

Are you able to access any password restricted page behind that apache server?

Are there other realms that require passwords?
Ralph Grothe
Honored Contributor

Re: apache problem

Your container probably lacks an Allow rule because it inherits from the restrictive Root directory / permissions which I bet has an "Order allow,deny" entry.
This means that anything beneath / will automatically implicitly switch to deny all unless it finds a contradicting explicit Allow rule in the respective container.
So either change the Order in your AuthType Basic container to "Order deny,allow" (which implicitly falls back to allow all), or explicitly add an "Allow from all" or an IP address/network (range).
If you go for the IP address restriction and you want both Basic authentication *and* by source IP address access restrictions to take effect you also need to insert a "Satisfy all" into your container.
After having edited the changes to your httpd.conf send the master httpd a SIGUSR1 (graceful) or SIGHUP and retry accessing.
Madness, thy name is system administration