cancel
Showing results for 
Search instead for 
Did you mean: 

auto logout

SOLVED
Go to solution
hhhyyy
Occasional Contributor

auto logout

OS is Tru64 UNIX 5.1A.When a user login to system and have no actions,then after about 2 hours the user logout automatically.How can I avoid this?Thank you.
8 REPLIES
Venkatesh BL
Honored Contributor
Solution

Re: auto logout

You must be running Enhanced security. right?
Michael Schulte zur Sur
Honored Contributor

Re: auto logout

Hi,

check if the environment variable TMOUT is set, not 100% sure about spelling. This terminates the shell after x seconds of inactivity.

greetings,

Michael
Venkatesh BL
Honored Contributor

Re: auto logout

From ksh manpage:

TMOUT
If set to a value greater than 0 (zero), the shell terminates if a command is not entered within the prescribed number of seconds after issuing the PS1 prompt.
(Note that the shell can be compiled with a max imum bound for this value that cannot be exceeded.)

hhhyyy
Occasional Contributor

Re: auto logout

Thank you.TMOUT=0.
hhhyyy
Occasional Contributor

Re: auto logout

Thank you.I check the value of TMOUT,it is 0.
Ivan Ferreira
Honored Contributor

Re: auto logout

This can be a keepalive tcp setting, and can be set on the OS or on a router/switch.

You should verify keepalive tcp settings.

# sysconfig -q inet | grep keep

See the manuals for reference about how to configure the values.

Anyway, is good idea to have some session time control for security.
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
hhhyyy
Occasional Contributor

Re: auto logout

Thank you.
Michael Schulte zur Sur
Honored Contributor

Re: auto logout

Hi,

Did you solve the problem?
If you would you please post the solution?

Thanks,

Michael