HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
cancel
Showing results for 
Search instead for 
Did you mean: 

automount error

 
SOLVED
Go to solution
shameemsoft
Frequent Advisor

automount error

Dear,

we have HP UNIX 11.31. we are getting following error continously.

"automountd[3363]: match_addr: getaddrinfo failed: host nor service provided, or not known"

/etc/auto.master configuration below

/net -hosts -nosuid,soft,nobrowse

It is hosts built in map.

We were using DNS before. But not used now and entry was there in /etc/resolv.conf. I commented that entry and removed not reachable IP in /etc/hosts file.

SMTP relay is not enabled.

But still we are getting this error continously. Kindly help me on this to resolve this issue.

Thanks
Shameem

18 REPLIES
mvpel
Trusted Contributor
Solution

Re: automount error

Perhaps another bit of software is trying over and over again to access a /net path for a host that doesn't exist? Running a "tusc" on the automountd may prove illuminating.

Also, make sure you have PHCO_39526 installed so you're using the latest possible version of the getaddrinfo() function.
shameemsoft
Frequent Advisor

Re: automount error

Dear,

Thanks for your response.

"tusc" is not installed in our servers. Is there any other way to find out the root cause?

Also PHCO_39526 is not installed in our servers. This issue occur in only few servers not all servers. But this patch is not installed in all our servers.

Kindly advise on this.



R.K. #
Honored Contributor

Re: automount error

shameemsoft
Frequent Advisor

Re: automount error

Thanks RK

Following solution is specified on this thread.

To set some pararameters in /etc/rc.config.d/nfsconf to off if I am not using them such as;
AUTOFS=0
NFS_CLIENT=0
NFS_SERVER=0
START_MOUNTD=0

But we are using NFS share and it is configured in /etc/dfs/dfstab file.

Kindly help me on this.
Dave Olker
HPE Pro

Re: automount error

Hi Shameem,

> But we are using NFS share and it is
> configured in /etc/dfs/dfstab file.

Is this system the NFS client or server? If you're configuring filesystems in the dfstab file that sounds like the server. AutoFS is strictly a client-side application used to mount NFS filesystems from remote servers. If this system is a server and does not need to mount NFS filesystems from other servers, especially using AutoFS, then it should be safe to disable AutoFS by setting those tunables in the nfsconf file to 0.

Regards,

Dave
shameemsoft
Frequent Advisor

Re: automount error

Thanks Dave.

Most of our HP UNIX servers are act as NFS server & client due to SAP requirement. We are mounting some directory for SAP application requirement using NFS only.

So sometime it act as NFS client & NFS server.

shameemsoft
Frequent Advisor

Re: automount error

Dear,

Any luck on this issue?

Dave Olker
HPE Pro

Re: automount error

Hi Shameem,

Are you still experiencing problems or have you resolved this?

Dave
shameemsoft
Frequent Advisor

Re: automount error

Thanks Dave.. still we are facing this issue

No solution. If you have anything please let me know

Dave Olker
HPE Pro

Re: automount error

I'm happy to try to resolve this. If this is something you can reproduce at will then I'd like you to enable debug AutoFS logging and capture a couple of these errors. To do this you send a SIGUSR2 signal to the automountd daemon:

# kill -17

This should toggle on debug logging to the file /var/adm/automount.log. Wait until you see a couple instances of the error message you're concerned about and then send another SIGUSR2 to the same pid to toggle debug logging off.

Either post or send me (dave.olker@hp.com) the following files:

/var/adm/automount.log
/etc/auto_master
ANY other autofs map referenced in the auto_master file
/etc/resolv.conf

That should help me get started.

Regards,

Dave
Tim Nelson
Honored Contributor

Re: automount error

Another option.

turn off automount and put entries in /etc/fstab and be done with it ?

shameemsoft
Frequent Advisor

Re: automount error

Thanks Dave,

Kindly find the automount.log details in the attachment.

#cat /etc/auto_master
/net -hosts -nosuid,soft,nobrowse

we are not using DNS. we are using only /etc/hosts for name resolution.

Thanks Tim for your response.



Dave Olker
HPE Pro

Re: automount error

Hi Shameem,

The entire log file is filled with repeating entries like this:

Jan 16 09:21:24 t1 LOOKUP REQUEST: Sat Jan 16 09:21:24 2010
Jan 16 09:21:24 t1 name=usr.scratch[] map=-hosts opts=nosuid,soft,nobrowse path=/net direct=0
Jan 16 09:21:24 t1 mapline: -hosts
Jan 16 09:21:24 t1 do_mapent_hosts: host usr.scratch
Jan 16 09:21:24 t1 ping: usr.scratch timeout=15 request vers=3 min=2
Jan 16 09:21:24 t1 pingnfs FAIL: can't get nfs version
Jan 16 09:21:24 t1 do_lookup1: action=2 wildcard=FALSE error=2
Jan 16 09:21:24 t1 LOOKUP REPLY : status=2


Someone or some application is constantly trying to access the path "/net/usr.scratch" and AutoFS interprets the string "usr.scratch" as the NFS server's hostname. It tries to resolve this host name so it can contact it to discover what filesystems it is exporting.

Something tells me you don't really have a server named "usr.scratch". :)

Does the name "usr.scratch" mean anything significant for the applications you run on this client? Do you have something set incorrectly in one of your environment variables, like PATH or some library pathname variable?

One other comment. AutoFS is an optional product. You're not required to use AutoFS to mount filesystems. Since this entire log file shows no actual MOUNT requests, are you certain you really need to use AutoFS at all? As Tim and others have said, could you configure the NFS filesystems you need in the /etc/fstab file and simply disable AutoFS? Or are there really some NFS filesystem managed by AutoFS used by your applications?

Regards,

Dave

Re: automount error

>Dave: Do you have something set incorrectly in one of your environment variables

Or a symlink to /net/usr.scratch.
shameemsoft
Frequent Advisor

Re: automount error

Thanks Dave/Dennis for your response.

We checked our SAP application and didn't access /net/use.scratch from application level.

Also environment variable & other PATH is configured properly.

We dont have hostname like usr.scratch :)

This error is repeating in 4 servers in our environment.

Also we dont have symblic link for /net/usr.scratch as Dennis said.

>>are there really some NFS filesystem managed by AutoFS used by your applications?

I need to cross check whether AUTOFS used by application or not. I will check and get back to you...

But I would like to find out root cause of this issue ;).

Thanks in Advance

Re: automount error

>We checked our SAP application and didn't access /net/usr.scratch from application level.

You could use "strings -a" on each of your executables and shlibs and look for "usr.scratch".

You also know it happened at "Jan 16 09:21:24" and other times in your log. What was running then?

You can also use tusc to look at opens.

>Also we don't have symbolic link for /net/usr.scratch as Dennis said.

I assume you used find(1) to search for all symlinks and then grep?

>I would like to find out root cause of this issue

You are trying to open a file in /net/usr.scratch/.
shameemsoft
Frequent Advisor

Re: automount error

Thanks a lot Gentlemen for your response.

Not able to find which application trying to access this share.

Finally I have disabled default map entry.

#/net -hosts -nosuid,soft,nobrowse

Now this error is not repeating..

Thank you all.

Shameem
shameemsoft
Frequent Advisor

Re: automount error

Thank You