cancel
Showing results for 
Search instead for 
Did you mean: 

backup to local tape

Tammy Liang
Regular Advisor

backup to local tape

I have been failing backup to local tape drive with tar command. Also fail on mt command.
I can see /dev/st0 tape drive device. The HP SIM home page also shows the status of tape drive is okay.
I am sure there is DAT 72 tape in the drive.
It fixed the problem for few days after system reboot. But I can not reboot the system all the time.
Thanks for any suggestion and reply.
Below are the commands I ran.
root# ll /dev/st0
crw-rw---- 1 root disk 9, 0 Oct 10 13:00 /dev/st0
root# mt -t /dev/st0 rewind
/dev/st0: No such device or address

# tar -cvf /dev/st0 exitcode
tar: /dev/st0: Cannot open: No such device or address
tar: Error is not recoverable: exiting now
root#

Tammy
take easy, enjoy life
3 REPLIES
Dennis Handly
Acclaimed Contributor
Peter_505
Advisor

Re: backup to local tape

A couple of things....

~ does /var/log/messages show the tape device?
~ does the tape device show up in /proc/scsi/scsi?

If the device doesn't show up there the controller is not talking to the device (hardware issue)

have you tried unloading and reloading the scsi drivers?

modprobe -r mptctl
modprobe -r mptscsih
modprobe -r mptbase

then:

modprobe mptbase
modprobe mptscsih
modprobe mptctl

~peter
Tammy Liang
Regular Advisor

Re: backup to local tape

Thank you for replying.
Check all and see tape drive in kernel files.
HP recommend to update the tape drive firmware.Can I update tape drive on-line?

Tammy
take easy, enjoy life