cancel
Showing results for 
Search instead for 
Did you mean: 

Re: bdf/df very slow

 
SOLVED
Go to solution
balaji_vvv
Frequent Advisor

bdf/df very slow

I have newly built system running 11.23 on PA-risc and its attached to DS2300 disksystem. The problem is when i'm creating tar files,
bdf command really hangs/slow. Its coming back, but its very slow (5-10min) otherwise its quick. I dont have any NFS in my fstab and have 32G memory with dbc_max/min values set at 10/5. Any idea why its hanging or slow?
10 REPLIES 10
Torsten.
Acclaimed Contributor

Re: bdf/df very slow

Many possible reasons ... one of them is a problem with SCSI bus. What is the dip switch setting? Are terminators installed???

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
balaji_vvv
Frequent Advisor

Re: bdf/df very slow

Yes. Terminators are installed, dip switch setting to split bus mode and i used lvm mirroring across controllers.
balaji_vvv
Frequent Advisor

Re: bdf/df very slow

I want to rule out scsi reasons. As i just tried to create tar file (6g) on /var vg00 file system (local disk) and it hangs in the same way? Is there any kernel parameter i'm missing?

I set dbc_max/min to 50/5 still the same?
Bill Hassell
Honored Contributor
Solution

Re: bdf/df very slow

bdf is often underutilized. You can specify a directory, a file or simply . (the current PWD). You need to identify the problem filesystem by running bdf on each mountpoint one at a time. Here's a quickie to time each bdf run:

for MNT in $(mount -l|awk '{print $1}')
do
time bdf $MNT
echo "\n\n================"
done

Something is definitely not right if bdf takes more than a few seconds. Also, try grabbing the bdf details with -s (11.23 and higher):

bdf -ls

If that runs fast, there is a *LOT* filesystem changes going on. Use sar -a to see what is happening in the directories:

sar -a 2 10


Bill Hassell, sysadmin
balaji_vvv
Frequent Advisor

Re: bdf/df very slow

Thanks for the info. My problem is little different i think. The issue is that it behaves normal during regular time, but when im running tar cvf command, it hangs and its slow (slow in heavy IO) and i believe bdf invoke "sync" command, also when im doing tar, even sync command is slow response. But it behave normal with no I/O. i have tested tar cvf across all file system, its doing the same thing (local and disk jbods)
balaji_vvv
Frequent Advisor

Re: bdf/df very slow

Okie, i got it. The culprit is dbc_max value, i tried high values like 50/5 and 20/5 it didnt work. But when i changed it to 7/5 everything is fast now.
balaji_vvv
Frequent Advisor

Re: bdf/df very slow

Can i set dbc_max and dbc_min with equal values for constant buffer cache value? Is there any advantage/disadvantage doing this?
Elmar P. Kolkman
Honored Contributor

Re: bdf/df very slow

Setting to exact the same value is not recommended (not sure if it's possible at all) but the problem you have is the same as we ran into on HP-UX 11.11. The algorithms for the freeing and allocating of DBC really suck, and apparently (we don't run 11.23) they still do. For allocation, it needs to free up otherwise used memory, for freeing it needs to sync that memory. Both heavy operations.

Having a value of about the same value will solve the issue, and since you have 32 G of memory, having it around 5-10 will help. It depends on the load what value is best. For starters use 5/6. Check out. Then you might try 9/10 and check out again.
Every problem has at least one solution. Only some solutions are harder to find.
Hakki Aydin Ucar
Honored Contributor

Re: bdf/df very slow

bdf list the mount points, so mostly slowness indicates an nfs problem,
check this link:
http://forums11.itrc.hp.com/service/forums/questionanswer.do?threadId=1438990