System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

bonding broadcom netextreme , packet droping

DeafFrog
Valued Contributor

bonding broadcom netextreme , packet droping

Dear Gurus ,

I had once configured bonding successfully with qlogic card.Redhat eL5.1 , i remember hashing out the mac add from each of the ifcfg-eth0/1 files and adding these lines in modprobe.conf

options qla2xxx ql2xmaxqdepth=16 qlport_down_retry=30 ql2xloginretrycount=30 ql2xfailover=1 ql2xlbType=1 ql2xautorestore=0xa0 ConfigRequired=0
remove qla2xxx /sbin/modprobe -r --first-time --ignore-remove qla2xxx && { /sbin/modprobe -r --ignore-remove qla2xxx_conf; }

now the eth cards are broadcom netextreme , os is EL5.5 red hat , i configured the bonding in the same way , bit i see the ping not continous successful .
modprobe.conf is :
alias scsi_hostadapter mpt2sas
alias eth0 bnx2x
alias eth1 bnx2x
alias eth2 bnx2
alias eth3 bnx2
alias scsi_hostadapter1 usb-storage

ifcfg-bond0 is :

DEVICE=bond0
IPADDR=192.168.XX.XXX
NETMASK=255.255.255.0
USERCTL=no
BOOTPROTO=none
ONBOOT=yes
BONDING_OPTS="mode=0 miimon=100"

and then resrted the network , but still the ping is droping interminently , not successful.

1) if anyone has working modprobe.conf , bonding configured with 2 1G broadcom netextreme eth card please paste , also ifcfg-bond0 , ifcfg-eth0 , ifcfg-eth1 files.

2) steps to configure the same.

Many thanks ,


FrogIsDeaf
4 REPLIES
Alzhy
Honored Contributor

Re: bonding broadcom netextreme , packet droping

Wow - I did not know Qlogic FC Cards can do ethernet/IP too -- but anyways, I think you're missing something.

Here's my ifcfg files for a fail-over bond:

# >cat ifcfg-bond0
DEVICE=bond0
IPADDR=192.168.122.100
NETWORK=192.168.122.0
NETMASK=255.255.255.0
USERCTL=no
BOOTPROTO=none
ONBOOT=yes
BONDING_OPTS="mode=active-backup miimon=100 primary=eth0"

# >cat ifcfg-eth0
# Broadcom Corporation NetXtreme II BCM5709 Gigabit Ethernet
DEVICE=eth0
USERCTL=no
ONBOOT=yes
MASTER=bond0
SLAVE=yes
HWADDR=1C:C1:DE:20:D9:2A

# >cat ifcfg-eth1
# Broadcom Corporation NetXtreme II BCM5709 Gigabit Ethernet
DEVICE=eth1
USERCTL=no
ONBOOT=yes
MASTER=bond0
SLAVE=yes
HWADDR=1C:C1:DE:20:D9:2C

My /etc/modprobe.conf only has the following:

alias bond0 bonding
alias bond1 bonding

(I have 2 bond devices on this server which is a node of a KVM Cluster)

Hope this helps sir.


Hakuna Matata.
DeafFrog
Valued Contributor

Re: bonding broadcom netextreme , packet droping

Hello Sir,

Yes i got all mixed up.

The earlier configuration was :(from lspci)

06:00.0 Fibre Channel: QLogic Corp. ISP2432-based 4Gb Fibre Channel to PCI Express HBA (rev 03)
06:00.1 Fibre Channel: QLogic Corp. ISP2432-based 4Gb Fibre Channel to PCI Express HBA (rev 03)

0a:04.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5715S Gigabit Ethernet (rev a3)
0a:04.1 Ethernet controller: Broadcom Corporation NetXtreme BCM5715S Gigabit Ethernet (rev a3)

The present one is :

01:00.0 Ethernet controller: Broadcom Corporation NetXtreme II BCM5709S Gigabit Ethernet (rev 20)
01:00.1 Ethernet controller: Broadcom Corporation NetXtreme II BCM5709S Gigabit Ethernet (rev 20)

04:00.0 Ethernet controller: Broadcom Corporation NetXtreme II BCM57711 10-Gigabit PCIe
04:00.1 Ethernet controller: Broadcom Corporation NetXtreme II BCM57711 10-Gigabit PCIe

the reason for this mixed up was a previous working modprobe.conf file saved somewhere:
-------
cat /etc/modprobe.conf
alias eth0 tg3
alias eth1 tg3
alias scsi_hostadapter cciss
alias scsi_hostadapter1 qla2xxx_conf
alias scsi_hostadapter2 qla2xxx
alias scsi_hostadapter2 usb-storage
alias bond0 bonding
options bond0 mode=1 miimon=100

alias eth2 tg3
alias eth3 tg3
options qla2xxx ql2xmaxqdepth=16 qlport_down_retry=30 ql2xloginretrycount=30 ql2xfailover=1 ql2xlbType=1 ql2xautorestore=0xa0 ConfigRequired=0
remove qla2xxx /sbin/modprobe -r --first-time --ignore-remove qla2xxx && { /sbin/modprobe -r --ignore-remove qla2xxx_conf; }
---------
now for iscsi LUn being acessed thru broadcom 10g iSCSI card ,is there some entry in modprobe.conf, if you have similar configuration on some
server can you please paste modprobe.conf.

Regards,
FrogIsDeaf
Thomas Callahan
Valued Contributor

Re: bonding broadcom netextreme , packet droping

First, mode=0 is active/active mode, which will not work unless your backend network is specifically allowing that kind of traffic. mode=1 is active/backup

I recommend using mode=1 unless there is a specific reason you need active/active, it's more stable, and requires no network reconfiguration.

For mode=1...

Your config should look like this:

modprobe.conf:

alias bond0 bonding
alias bond1 bonding
options bonding miimon=100 mode=1 max_bonds=5

ifcfg-bond0:
DEVICE=bond0
USERCTL=no
ONBOOT=yes
BROADCAST=XX.XX.XX.255
NETWORK=XX.XX.XX.0
NETMASK=255.255.255.0
GATEWAY=XX.XX.XX.XX
IPADDR=XX.XX.XX.XX


ifcfg-eth0:
DEVICE=eth0
HWADDR=XX:XX:XX:XX:XX:XX
USERCTL=no
ONBOOT=yes
MASTER=bond0
SLAVE=yes
BOOTPROTO=none


ifcfg-eth1:
DEVICE=eth1
HWADDR=XX:XX:XX:XX:XX:XX
USERCTL=no
ONBOOT=yes
MASTER=bond0
SLAVE=yes
BOOTPROTO=none
Thomas Callahan
Valued Contributor

Re: bonding broadcom netextreme , packet droping

You don't actually need two bond devices, that was just to show how to do it "IF" you actually needed two. max_bonds is required if you are using more than one bonding device.