cancel
Showing results for 
Search instead for 
Did you mean: 

can dd rdsk but not dsk

SOLVED
Go to solution
Wes Kaufmann
Super Advisor

can dd rdsk but not dsk

I have a 11.31 IA 64 system. The system had a problem and I have recoved everything but access to vg01.

dd to raw device file works but not to a block file.

dd if=/dev/rdsk/c11t0d1 of=/dev/null bs=1024k count=200
200+0 records in
200+0 records out
ac2opv:/stand#: dd if=/dev/dsk/c11t0d1 of=/dev/null bs=1024k count=200
dd read error: I/O error
0+1 records in
0+1 records out
5 REPLIES
Torsten.
Acclaimed Contributor

Re: can dd rdsk but not dsk

Whatever you do with 11.31 regarding disks, you should use the new device files, e.g.

/dev/(r)disk/disk123

Use

# ioscan -m dsf

to find out.

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Wes Kaufmann
Super Advisor

Re: can dd rdsk but not dsk

Doesn't matter if I use legacy or the new persistant device file. Using dd on the block file fails.
smatador
Honored Contributor
Solution

Re: can dd rdsk but not dsk

Hi,
Very interesting issue.
Have you look this thread
http://forums11.itrc.hp.com/service/forums/questionanswer.do?threadId=1278792
In fact, with my experience, Hpux 11.31 does not like powerpath at all, but if you have an EMC array with actif/passif controler [it could happen with old firmware], it should be clearly more interesting to install powerpath. So normally dd can read raw or block file, i think but not sure, this issue is probably about multipathing.
Hope it helps
Wes Kaufmann
Super Advisor

Re: can dd rdsk but not dsk

Actually, same exact issue in the link you provide.

I was using PowerPath and suddenly I was having problems with A SG lock disk. I was going to try removing powerpath and just use the legacy device files. But, on the good system I can do a dd on the block files, same array on the bad system doesn't do a dd on block files.

So based on the last thread perhaps powerpath has left some goodies?

FYI, I was going to use the new persistent device file but was having timeout issues with a EMC CX500 array so I than tried powerpath and it mostly worked for a month. Than suddenly an issue appeared. When one node in a SG cluster rebooted the lock disk on live node would go down. I found that I could get the lock disk on the live node back up by simply running a ioscan -f.....

So trying to go without powerpath and just do legacy device files with alternate links. Not a lot of IO so wasn't worried about loadbalancing.
Wes Kaufmann
Super Advisor

Re: can dd rdsk but not dsk

I don't believe I will have time to resolve the issue but I agree that PowerPath probably makes a setting to the system that then makes the system incompatible with direct native connectivity to the array.

I was going to set some attributes with the scsimgr command but I found a patch for powerpath and I'm back in business.

HP support says a EMC array is supported if ALU is enabled so it seems that you would need to turn on ALU.

scsimgr -v get_info -D /dev/rdisk/disk12' we have
...
Asymmetric logical unit access supported = No

Note, I did run the native Persistent device file for about a week against the EMC array but I would get timeout issues and the volume group would fail for a few hours and than magically turn back on. I had a call open with HP and it was escalated to the lab but I ran out of time and was forced to use PowerPath and put the system in Production.

Installing PowerPath IA64 patch 5.1.1 resolved my issues with a lock disk failing on a SG node.

For now I am stuck with PowerPath since I don't know what settings to change to the system if I remove PowerPath and I will probably still have timeout issues.