cancel
Showing results for 
Search instead for 
Did you mean: 

can't build kernel

EL HARTI, Hicham
Occasional Visitor

can't build kernel

Hi,

I'm trying to build a new kernel at node2 on a cluster system (2 nodes Tru64 Unix: node1: V5.1! node2: P5.1A, DEC ES45) because of sizer -z ==> P5.1A (and not V5.1A).

I run: config -c node2 and get the following error:

==============================================
***PERFORMING KERNEL BUILD ***
Configuration file has errors
./alpha/file.hal: Duplicate file OPTIONS/bparm
Error: Module bparm already exists
=========================================================

The listing files on the directory /usr/sys/conf/node2/alpha is:
rwxr-xr-x 2 root system 8192 Dec 29 15:47 .
drwxr-xr-x 4 root system 8192 Dec 29 15:52 ..
-r--r--r-- 1 bin bin 1301 Aug 25 2000 .Old..devices
-r--r--r-- 1 bin bin 13012 Aug 25 2000 .Old..files
-r--r--r-- 1 bin bin 11351 Aug 25 2000 .Old..files.hal
-r--r--r-- 1 bin bin 22515 Aug 25 2000 .Old..files.io
-r--r--r-- 1 bin bin 6679 Aug 25 2000 .Old..template.mk
-r--r--r-- 1 bin bin 1301 Aug 25 2000 devices
-r--r--r-- 1 bin bin 13012 Aug 25 2000 files
-r--r--r-- 1 bin bin 11205 Jan 16 2002 files.hal.OSHHWBASE520
-r--r--r-- 1 bin bin 11278 May 13 2002 files.hal.OSHHWBASE521
-r--r--r-- 1 bin bin 11351 Aug 25 2000 files.hal.OSHHWBASE523
-r--r--r-- 1 bin bin 11278 May 13 2002 files.hal.old
-r--r--r-- 1 bin bin 24164 Jan 25 2003 files.io
-r--r--r-- 1 bin bin 20664 Jan 16 2002 files.io.OSHHWBASE520
-r--r--r-- 1 bin bin 20664 Jan 16 2002 files.io.OSHHWBASE521
-r--r--r-- 1 bin bin 22515 Aug 25 2000 files.io.OSHHWBASE523
-r--r--r-- 1 bin bin 6539 Jan 25 2003 template.mk
-r--r--r-- 1 bin bin 6679 Aug 25 2000 template.mk.OSHHWBASE523
=====================

Do you have any idea to make buiding kernel possible
4 REPLIES
EL HARTI, Hicham
Occasional Visitor

Re: can't build kernel

Some corrections:
node1: sizer -v ==> V5.1A
node2: sizer -v ==> P5.1A

To build the kernel I run:
doconfig -c NODE2
Johan Brusche
Honored Contributor

Re: can't build kernel


Since you told me your have tried upgrading from V5.1A to V5.1B, it looks like NODE2 is your lead member. The .Old.. files for the other member NODE1 are there (so you ran clu_upgrade setup), but the new files file.hal and file.io do NOT seem to be there, so where did your installupdate fail ? or haven't you run installupdate yet ?

clu_upgrade status ?

BTW if you booted NODE2 from genvmunix. it's normal that it shows P5.1A

__ Johan.

_JB_
Michael Schaefer_2
Occasional Advisor

Re: can't build kernel


The result of clu_upgrade status is:
==============================================================
Stage Status Date

setup started: Tue Dec 28 09:47:38 MET 2004
completed: Tue Dec 28 10:32:02 MET 2004

preinstall started: Tue Dec 28 10:44:20 MET 2004
completed: Tue Dec 28 12:25:17 MET 2004

patch started: Tue Dec 28 15:46:57 MET 2004
completed: Tue Dec 28 17:00:39 MET 2004
================================================================

After preinstall stage I couldn't run intallupdate with the error:
===============================================================
*** START UPDATE INSTALLATION (Tue Dec 28 14:48:38 MET 2004) ***
FLAGS: -nogui



You must have one of the following versions of the Operating System product loaded on your system before you can update to Compaq Computer Corporation Tru64 UNIX V5.1B:

Compaq Tru64 UNIX V5.1A

Please refer to the Compaq Computer Corporation Tru64 UNIX V5.1B Installation Guide for additional information.

Returning system to Pre-Update state...done.

Exiting Update Installation...
===============================================================
Then I started the installation of PatchKit3, and I think after the patch installation The system became instable.

Johan Brusche
Honored Contributor

Re: can't build kernel

+

Hicham,

Some patches were probably rejected for installation due to
module conflits. In kit #3 OSFPAT00084600520 provides a new
"files.hal",dated 13-may-2002, but you do not have that file.
You have a "file.hal.old", so where is the original ?

Did you run a baseline adjustment ? If not, run it and resolve any
unknown/missing file conflicts, then run a kit#3 install again
and make sure no patches were rejected due to conflicts.

Regards,
Johan.


_JB_