System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

can't change root pw after Ignite recovery

JLee_1
Advisor

can't change root pw after Ignite recovery

Hello, All

I'm having an issue authenticating with the root password after Igniting one of my HP-UX boxes (11.11 - trusted mode). And I'm not able to change the root password. I've tried booting into single user mode and resetting, but it prompts me for the old password and it's not accepting it (though I'm 99.99% sure I'm entering it correctly). I've also tried changing it from the command line using another account with uid=0, but that also prompts for the old password.

Any thoughts on what could be causing this, and how I can get the password reset?

Thanks in advance.
2 REPLIES
Robert-Jan Goossens
Honored Contributor

Re: can't change root pw after Ignite recovery

JLee,

Can you login to your 11.11 system in single user mode?

# mount /tmp
# mount /var
example
# vi /tcb/files/auth/r/root

change:
:u_pwd=YfdfdTmswL7o/.:\

to

:u_pwd=:\

:wq!

# passwd root

Regards,
Robert-Jan
JLee_1
Advisor

Re: can't change root pw after Ignite recovery

Thanks for the quick response, Robert -

That was actually going to be the next thing I tried. I went another route and changed the uid of the root account temporarily to get around having to provide the old password. Dirty solution, I know... but it worked, so I've got a password I can use now. But I'm noticing some more quirkiness. Looks like the environment variables of the server didn't come over with the Ignite image...not sure why. uname -a returns a hostname of "unknown", and all my environment variables are gone. Something's not kosher with the Ignite's I've used I guess. I've tried a couple different tapes with the same results.