System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

can't send mail thru sendmail

sammysammy
Frequent Advisor

can't send mail thru sendmail

Hi,

I want to use commandline mail me@mailserver.com < /.cshrc to send me a test email, but I can receive the email with this command.

The server is a 5.1B-4 system with sendmail running:
# ps -ef | grep sendmail
root 695 1 0.0 Mar 13 ?? 0:03.51 sendmail: accept -bd -q15m -om
root 405413 695 0.0 17:01:31 ?? 0:00.01 sendmail: ./l2S6 -bd -q15m -om
root 405492 178164 0.0 17:07:08 pts/10 0:00.00 grep sendmail
#

How to troubleshoot this problem and how to fix it?

Your suggestion is highly regarded.
Thanks
5 REPLIES
sammysammy
Frequent Advisor

Re: can't send mail thru sendmail

Hi,

I found they are still in the mail queue in the 5.1B4 system where I am sending the mail from:

# pwd
/var/spool/mqueue
# ls -l
total 6
-rw------- 1 root system 1322 Mar 28 16:18 dfl2S6IJc403249
-rw------- 1 root system 1322 Mar 28 16:23 dfl2S6NGu404758
-rw------- 1 root system 492 Mar 28 17:11 qfl2S6IJc403249
-rw------- 1 root system 492 Mar 28 17:11 qfl2S6NGu404758
#

Thanks
Vladimir Fabecic
Honored Contributor

Re: can't send mail thru sendmail

What is the output of:
# mailq
In vino veritas, in VMS cluster
Sunilkumar S M
Occasional Visitor

Re: can't send mail thru sendmail

Hi,

I am not sure if you have configured the server (sendmail) or not. If not, please reconfigure using mailsetup or sysman.

Regards,
Sunil.
sammysammy
Frequent Advisor

Re: can't send mail thru sendmail

Hi,

The mailq shown the following message:
# mailq
/var/spool/mqueue (2 requests)
----Q-ID---- --Size-- -----Q-Time----- ------------Sender/Recipient------------
l2S6NGu404758* 1322 Wed Mar 28 16:23 root
(Deferred: Connection timed out with postoffice.telstra.net.)
sammy@myco.com.au

I am not sure whether the sendmail service is setup in this system. I will have a look at the sendmail setup.

Thanks
Vladimir Fabecic
Honored Contributor

Re: can't send mail thru sendmail

"(Deferred: Connection timed out with postoffice.telstra.net.)"
Are you sure everithing is OK with network?
Try to do:
# telnet postoffice.telstra.net 25
Also make sure that nothing is blocking your connection (from postoffice.telstra.net ; i.e. some filter or simular).
Of course, it can also be your sendmail configuration.
In vino veritas, in VMS cluster