cancel
Showing results for 
Search instead for 
Did you mean: 

cc compiler

yash123
Regular Advisor

cc compiler

Hi,
I have a requirement of latest bundled cc compiler on HP UX 11.23 itanium server
Currently, the version is:
# cc -V
(Bundled) cc: HP aC++/ANSI C B3910B A.05.50 [May 15 2003]
# swlist | grep -i c++
B3911DB C.11.23.12 HP aC++ Compiler (S700)
PHSS_35975 1.0 aC++ Compiler (A.06.14)
PHSS_35978 1.0 aC++ Runtime (IA: A.06.14, PA: A.03.76)

cc -V shows old bundle.

Please advice me on this.

Regards
Yash

3 REPLIES
Steven Schweda
Honored Contributor

Re: cc compiler

> I have a requirement of latest bundled cc
> compiler [...]

Do you want the bundled C compiler (which
comes with HP-UX), or do you want the
optional, extra-cost "aC++ Compiler"?

I know nothing, but this sounds like another
case of Oracle asking for compiler patches
even though the compiler is not installed.
(If so, a Forum search for keywords like
"Oracle compiler patch" should find many
old discussions.)

From where did this "requirement" come?
Dennis Handly
Acclaimed Contributor

Re: cc compiler

>I have a requirement of latest bundled cc compiler on HP UX 11.23 Integrity.

This is a contradiction in terms. The bundled C compiler is always the oldest. It is not patchable and not for development. But you can use it to install Oracle.

To get a newer compiler, A.06.22, you must purchase it.
You currently only have the A.06.14 aC++ compiler.
yash123
Regular Advisor

Re: cc compiler

found solution