cancel
Showing results for 
Search instead for 
Did you mean: 

cd not mounting

Abhirama.M.V
Occasional Advisor

cd not mounting

hi all..
i got this error (mount: No medium found) when i entered mount /dev/cdrom /mnt/cdrom in my frdora 7 box.
my /etc/fstab is like :
proc /proc proc defaults 0 0
LABEL=/ / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
tmpfs /dev/shm tmpfs defaults 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
sysfs /sys sysfs defaults 0 0
proc /proc proc defaults 0 0
LABEL=SWAP-sda5 swap swap defaults 0 0

and my /etc/mtab is :
/dev/sda3 / ext3 rw 0 0
proc /proc proc rw 0 0
sysfs /sys sysfs rw 0 0
devpts /dev/pts devpts rw,gid=5,mode=620 0 0
/dev/sda2 /boot ext3 rw 0 0
tmpfs /dev/shm tmpfs rw 0 0
usbfs /proc/bus/usb usbfs rw 0 0
tmpfs /dev tmpfs rw,size=10M,mode=0755 0 0
none /proc/sys/fs/binfmt_misc binfmt_misc rw 0 0
sunrpc /var/lib/nfs/rpc_pipefs rpc_pipefs rw 0 0

and i tried mount /media/cdrom i got :
mount: can't find /media/cdrom in /etc/fstab or /etc/mtab

how can i mount..!!!
help me plz..
usefull answers will get points....

thanx in advance...
3 REPLIES
Ivan Ferreira
Honored Contributor

Re: cd not mounting

Check if your cdrom is really mounted with the mount command and the mount point.

You can also use the "eject" command.
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
Ivan Ferreira
Honored Contributor

Re: cd not mounting

Oooops... sorry, the problem was to "mount", not umount.

Ok, (mount: No medium found).

You don't have a cdrom specification in fstab, so you should use the full mount command, for example:

mount /dev/cdrom /media/cdrom

If /dev/cdrom does not works, then try with /dev/hda /dev/hdb /dev/hdc or /dev/hdd dependind of where is connected your cdrom. You can check this from the output of dmesg.
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
skt_skt
Honored Contributor

Re: cd not mounting

Here is what i use in fstab of my RHEL servers

/dev/cdrom /mnt/cdrom udf,iso9660 noauto,owner,kudzu,ro 0 0

You may try mount w/o an fstab entry

mount -F iso9660 /dev/devicefile /mountpoint