HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
cancel
Showing results for 
Search instead for 
Did you mean: 

cdrom file issue

 
SOLVED
Go to solution
Katherine Lynn
Occasional Advisor

cdrom file issue

I'm on HP-UX 11.11. When I mount my cdrom and ls my files I get this. What's the deal?

# cd /cdrom
# ls
AUTORUN.INF;1 BSC2 DISK1 README.TXT;1 WELCOME.HTM;1 XMLPUB
BSC1 COMPONEN.LAB;1 READM000.TXT;1 SHELEXEC.EXE;1 WFEMB
# ls -l
total 148
-r-xr-xr-x 1 -1 -1 42 Feb 5 2008 AUTORUN.INF;1
dr-xr-xr-x 1 -1 -1 2048 Jan 19 2007 BSC1
dr-xr-xr-x 1 -1 -1 2048 Jan 19 2007 BSC2
-r-xr-xr-x 1 -1 -1 50 Feb 5 2008 COMPONEN.LAB;1
dr-xr-xr-x 1 -1 -1 2048 Oct 27 2006 DISK1
-r-xr-xr-x 1 -1 -1 776 Feb 5 2008 READM000.TXT;1
-r-xr-xr-x 1 -1 -1 2180 Feb 5 2008 README.TXT;1
-r-xr-xr-x 1 -1 -1 48640 Feb 5 2008 SHELEXEC.EXE;1
-r-xr-xr-x 1 -1 -1 9680 Feb 5 2008 WELCOME.HTM;1
dr-xr-xr-x 1 -1 -1 2048 Jan 19 2007 WFEMB
dr-xr-xr-x 1 -1 -1 2048 Jan 19 2007 XMLPUB

Here is my fstab file:

# System /etc/fstab file. Static information about the file systems
/dev/vg00/lvol3 / vxfs delaylog 0 1
/dev/vg00/lvol1 /stand hfs defaults 0 1
/dev/vg00/lvol4 /home vxfs delaylog 0 2
/dev/vg00/lvol5 /opt vxfs delaylog 0 2
/dev/vg00/lvol6 /tmp vxfs delaylog 0 2
/dev/vg00/lvol7 /usr vxfs delaylog 0 2
/dev/vg00/lvol8 /var vxfs delaylog 0 2
/dev/vga01/lvol1 /c1 vxfs rw,suid,largefiles,delaylog,datainlog 0 2
/dev/vga01/lvol4 /d2 vxfs rw,suid,largefiles,delaylog,datainlog 0 2
/dev/vga01/lvol5 /d3 vxfs rw,suid,largefiles,delaylog,datainlog 0 2
/dev/vga01/lvol8 /b8 vxfs rw,suid,largefiles,delaylog,datainlog 0 2
/dev/vga01/lvol2 /c2 vxfs rw,suid,largefiles,delaylog,datainlog 0 2
/dev/vga01/lvol3 /c3 vxfs rw,suid,largefiles,delaylog,datainlog 0 2
/dev/vga01/lvol6 /b2 vxfs rw,suid,largefiles,delaylog,datainlog 0 2
/dev/vga01/lvol7 /b4 vxfs rw,suid,largefiles,delaylog,datainlog 0 2
/dev/vga02/lvol1 /b1 vxfs rw,suid,largefiles,delaylog,datainlog 0 2
/dev/vga02/lvol2 /b3 vxfs rw,suid,largefiles,delaylog,datainlog 0 2
/dev/vga02/lvol3 /b5 vxfs rw,suid,largefiles,delaylog,datainlog 0 2
/dev/vga02/lvol5 /b9 vxfs rw,suid,largefiles,delaylog,datainlog 0 2
/dev/vga02/lvol6 ... swap pri=1 0 0
/dev/vga01/lvol10 ... swap pri=1 0 0
/dev/dsk/c3t2d0 /cdrom cdfs ro,suid 0 0
/dev/vga02/lvol4 /b6 vxfs rw,suid,largefiles,delaylog,datainlog 0 2
9 REPLIES
Fabio Ettore
Honored Contributor
Solution

Re: cdrom file issue

Hi,

try to mount the CD in this way:

unount /cdrom
mount -o rr /dev/dsk/c3t2d0 /cdrom

Anyway I don't think it's a good idea to have cdrom entry in /etc/fstab.

HTH.

Best regards,
Fabio
WISH? IMPROVEMENT!
Sunny123_1
Esteemed Contributor

Re: cdrom file issue

You get the deatils of the CD then whats the problem???
Katherine Lynn
Occasional Advisor

Re: cdrom file issue

Thanks! I can use my files now. What did I do wrong? Also, why is it a bad thing to have the cdrom in the fstab file?

OldSchool
Honored Contributor

Re: cdrom file issue

the "rr" option the previous poster noted is the rockridge extensions, which, among other things, gets rid of the the pesky ";1".
Fabio Ettore
Honored Contributor

Re: cdrom file issue

Hi,

better than a my explaination I suggest reading this article which well explained the reasons:

http://www.faqs.org/faqs/hp/hpux-faq/section-84.html

You CD was burned in RockRidge format, I saw that in the past for Oracle installation CDROM's.

About having /cdrom in fstab I'd prefer to not have it there, if for any reasons the CDROM has problems (or just you don't have put a CDROM inside) your boot could hang or something else strange.
In addition: as showed in this instance about your CDROM, it couldn't be right to mount the CDROM always like cdfs, for example in this instance you had to mount it in RockRidge. In general I'd prefer to not have it there.

HTH.

Best regards,
Fabio
WISH? IMPROVEMENT!
Katherine Lynn
Occasional Advisor

Re: cdrom file issue

Thanks so much -- you've all solved my problem and answered my questions extremely well.

Kathy
Katherine Lynn
Occasional Advisor

Re: cdrom file issue

The forum experts provided the answers to all of my questions.
Bill Hassell
Honored Contributor

Re: cdrom file issue

And the reasons not to have a CDROM in fstab are:

1. CDROM disks are extremely slow - bdf and other tools will appear to be very slow when they scan the CD.
2. If there is no CD in the drive, your system probably hang on bootup.
3. Somebody will try to do a find / (a very bad thing anyway) and the CD will take an hour or two to search.

Mount the CD when you need it. You can always use the (poorly documented) noauto option so it won't be mounted automatically but can still be mounted (with all the options) using: mount /cdrom:

/dev/dsk/c3t2d0 /cdrom cdfs noauto,ro,rr 0 0


Bill Hassell, sysadmin

Re: cdrom file issue

>Bill: Mount the CD when you need it. You can always use the (poorly documented) noauto option so it won't be mounted automatically but can still be mounted (with all the options)

Right. SAM has an option to do this. That's where I first noticed it.