HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
cancel
Showing results for 
Search instead for 
Did you mean: 

change MTU on hpux 11i

 
SOLVED
Go to solution
Andrea Rossi
Frequent Advisor

change MTU on hpux 11i

Hi all

I need to set the MTU to 1300 on the integrated network card of my rp3410.
sam does not allow to specify any MTU below 1500.
Do I have to change the driver to iether driver unless igelan?
And, in that case, how do I change it?
thanks in advance
10 REPLIES
Solution

Re: change MTU on hpux 11i

Why do you want to do this? Are you sure you want to change the MTU for the whole card, not just a path MTU to a specific destination (which you can do with the route command)?

Anyway you could try changing it from the command line using lanadmin:

lanadmin -m 0

shows MTU of lan0

lanadmin -M 1300 0

sets MTU of lan0 to 1300

Of course depending on the driver you may not be able to do this...

HTH

Duncan

HTH

Duncan
Michal Kapalka (mikap)
Honored Contributor

Re: change MTU on hpux 11i

hi,

lanadmin -M 1300 PPA_number

for permanent change edit *lanconf

ls -l /etc/rc.config.d/*lanconf

mikap
Andrea Rossi
Frequent Advisor

Re: change MTU on hpux 11i

I have to specify a static mtu for a destination the command with this command:
route -p 1300 add net x.x.x.x netmask x.x.x.x
gw x.x.x.x
is it?

Re: change MTU on hpux 11i

Yes that syntax looks correct to me... remember to make the chnage permanent across reboots you'll need to edit the file /etc/rc.config.d/netconf and add something like this:

ROUTE_DESTINATION[n]="net x.x.x.x"
ROUTE_MASK[n]="x.x.x.x"
ROUTE_GATEWAY[n]="x.x.x.x"
ROUTE_COUNT[n]="1"
ROUTE_ARGS[n]="-p 1300"

Note the value of [n] will need incrementing to 1 higher than the last entry in the file...

HTH

Duncan

HTH

Duncan
Michal Kapalka (mikap)
Honored Contributor

Re: change MTU on hpux 11i

hi,

you need to set it directly on LAN card.

via lanadmin = temporary and to the LANCARD_lanconf

in /etc/rc.config.d/

mikap
Michal Kapalka (mikap)
Honored Contributor

Re: change MTU on hpux 11i

sorry for my last post.
rick jones
Honored Contributor

Re: change MTU on hpux 11i

If you are adding a static PathMTU route, I would be curious to know why the standard, dynamic, PathMTU discovery is not working in this situation.
there is no rest for the wicked yet the virtuous have no pillows
Armin Kunaschik
Esteemed Contributor

Re: change MTU on hpux 11i

Rick,

there are Network departments or Network providers who disable ICMP completely for security reason. If they, for whatever reason, don't want to enable the necessary ICMP types to go through the firewalls, you are stuck at changing the MTU to a hard value. Usually it's better to tell them that certain ICMP types are necessary...

My 2 cents,
Armin
And now for something completely different...
rick jones
Honored Contributor

Re: change MTU on hpux 11i

Armin - yes, I figured as much, but I wanted to read it from the keyboard of the original author :) Perhaps I too often resort to a leading question or try to set-up an ambush :)
there is no rest for the wicked yet the virtuous have no pillows
Andrea Rossi
Frequent Advisor

Re: change MTU on hpux 11i

Hi

I contacted the network administrator in order to check the firewalls (cisco pix) and the vpn configuration.
I will let the forum know the results as soon as I know; then I will close the thread.

thanks