System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

change default ftp file permission

 
SOLVED
Go to solution
file system
Frequent Advisor

change default ftp file permission

Hi all
it have helped me out my problems. Thanks
so,
can you say that ftp file permission.
when I upload files to my linux box.
it has files with permission, -rw-r----- 1 affis affis 3268 7¿ù 30 09:17 PINGLOG
I want to change default file permission to '-rw-r--r--'
where is the configuaration file to change the permission?
when I ftp to login the ftp package is '[root@club root]# ftp
ftp> o
(to) 0
Connected to 0.
220 club FTP server (Version 5.60) ready.
334 Using authentication type GSSAPI; ADAT must follow
GSSAPI accepted as authentication type
GSSAPI error major: Miscellaneous failure
GSSAPI error minor: No credentials cache found
GSSAPI error: initializing context
GSSAPI authentication failed
334 Using authentication type KERBEROS_V4; ADAT must follow
KERBEROS_V4 accepted as authentication type
Kerberos V4 krb_mk_req failed: You have no tickets cached
Name (0:root):
ftp>
can you help me?
5 REPLIES
Vitaly Karasik_1
Honored Contributor

Re: change default ftp file permission

which ftp server do you use?
check its configuration manual.
file system
Frequent Advisor

Re: change default ftp file permission

gssftp is installed
Vitaly Karasik_1
Honored Contributor
Solution

Re: change default ftp file permission

I suggest you install vsftpd and configure file permissions using "umask" and "file_open_mode" option into vsftpd.conf.

gssftp is the kerberized ftp server, AFAIK, it's not what you need.
file system
Frequent Advisor

Re: change default ftp file permission

Thank you Vitaly Karasik
I have installed vsftp before you said.
but I'm not sure what I have'done before you said.
I have worked with gssftp and it has not working fine. finally I have installed vsftpd so it have worked fine.
it is clear that not gssftpd but vsftpd can upload via umask 022
Thank you Vitaly Karasik
skt_skt
Honored Contributor

Re: change default ftp file permission

also u can specify/change the umask in between the ftp process.

ftp> umask
200 Your current UMASK is 022
ftp> umask 022
200 UMASK set to 022