System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

cimprovagt burning CPU on rx6600

GXW_1
Frequent Advisor

cimprovagt burning CPU on rx6600

I just did a very simple 11i v3 BOE install on an rx6600 and almost immediately cimprovagt started burning 100% (of 1) CPU. Stopping cimserver cleared the problem, but starting it again brought it straight back. Question is, what does cimserver do for me? Do I really need it? Can I disable it or should I be investigating the cause of the loop? If so - what commands and/or logs will be useful in diagnosis other than syslog which has no clues.

System Page Size: 4Kbytes
Memory: 354008K (118932K) real, 559068K (208168K) virtual, 27957528K free Page# 1/8

CPU TTY PID USERNAME PRI NI SIZE RES STATE TIME %WCPU %CPU COMMAND
2 ? 17261 root 152 20 195M 60536K run 2:27 91.79 91.63 cimprovagt
8 ? 17259 cimsrvr 152 20 104M 45008K run 0:09 3.18 3.17 cimservermain
2 ? 17355 root 152 20 41524K 2960K run 0:07 2.77 2.77 cimprovagt
14 ? 17460 root 152 20 45892K 9196K run 0:05 1.85 1.84 cimprovagt
0 ? 1456 root 181 20 6600K 724K run 6:01 1.56 1.56 hp_unixagt
2 ? 17267 root 152 20 38864K 2320K run 0:04 1.12 1.11 cimprovagt
12 ? 79 root 152 20 35280K 31360K run 0:24 0.33 0.33 vxfsd
14 ? 1445 root 152 20 14780K 4300K run 0:21 0.18 0.18 snmpdm
2 ? 4144 root 168 20 11580K 1024K sleep 0:06 0.18 0.18 utild
12 ? 81 root 152 20 648K 576K run 0:01 0.18 0.18 pm_schedcpu
8 ? 17385 root 152 20 62832K 4084K run 0:00 0.17 0.17 cimprovagt
4 ? 71 root 152 20 1152K 1024K run 0:00 0.16 0.16 fb_daemon
6 ? 83 root 152 20 1152K 1024K run 0:45 0.16 0.16 pagezerod
10 pts/0 17828 root 178 20 7360K 1184K run 0:00 0.17 0.14 top
8 ? 17353 root 152 20 41792K 2948K run 0:00 0.12 0.12 cimprovagt
8 tty2p0 17315 root 168 20 7024K 848K sleep 0:00 0.10 0.10 top
8 ? 17352 root 152 20 41024K 2712K run 0:00 0.10 0.10 cimprovagt
12 ? 17607 root 152 20 20660K 2736K run 0:00 0.07 0.07 sshd:
14 ? 8 root 152 20 864K 768K run 0:00 0.06 0.06 ksyncer_daemon
14 ? 6014 root 152 20 50732K 2860K run 0:00 0.06 0.06 WbemWrapperMonitor
6 ? 17268 root 152 20 39144K 2468K run 0:00 0.06 0.06 cimprovagt
10 ? 17375 root 152 20 39300K 2396K run 0:00 0.06 0.06 cimprovagt
8 ? 17376 root 152 20 40792K 2520K run 0:00 0.06 0.06 cimprovagt
# model
ia64 hp server rx6600
6 REPLIES
mobidyc
Trusted Contributor

Re: cimprovagt burning CPU on rx6600

Hi,

very strange behavior.
Do you have anything relevant in your logs ?

I've searched through the patch database without success.

what is the WBEMServices release ?

cheers,
Cedrick Gaillard.
Best regards, Cedrick Gaillard
GXW_1
Frequent Advisor

Re: cimprovagt burning CPU on rx6600

I'm not familiar with WBEMServices so don't know where it keeps logs. I couldn't find any in e.g. /var/opt/wbem.

There is only this in syslog:

# grep -i wbem syslog.log
May 7 16:32:01 lgg159 cimserver[17259]: PGS10030: Started HP-UX WBEM Services version A.02.07.02.
#

Which answers your 2nd question :-)
Robert-Jan Goossens
Honored Contributor

Re: cimprovagt burning CPU on rx6600

There are a number of "support information" documents available on the Technical Database concerning cim and high cpu usage.

http://www13.itrc.hp.com/service/james/search.do?mode=text&searchString=cimprovagt+cpu&submit1=Search+%C2%BB&searchCrit=allwords&docType=SecurityBulletins&docType=EngineerNotes&docType=Drivers&dateSearchType=lastXdays&dateRange=all&startDateYear=1999&startDateMonth=0&startDateDay=1&endDateYear=2009&endDateMonth=4&endDateDay=7&resPerPage=20&sortCrit=rank

You could check if one of these correct your problem.

Regards,
Robert-Jan

Ps. you will need a support contract linked to your ITRC account to view these docs.
GXW_1
Frequent Advisor

Re: cimprovagt burning CPU on rx6600

Thanks for these 5 links Robert-Jan.

All look very similar to my problem.

1. They say this is a known issue in SFM C.02.00.04 and can be fixed by upgrading to version C.03.00.06.

Unfortunately I am already on SFM C.04.00.05

2. This relates to 11.23 and is intermittent - mine is constant 100% CPU

3.Disabling the procider seems to work - but feels like a workaround. This one suggests upgrading to B.06.00.04 so I went to download that and found SFM is only available for 11i v1 and 11i v2 - not 11i v3 so I am now thoroughly confused as I have it on 11i v3.

4. This again suggests upgrading components but is not specific enough, and again seems to be referring to an old version. The circumvention of running "cimserver -s" is certainly effective if a little over the top?

5. Not the same issue - my sfmdb user is fine.

So does anyone have any ideas what versions of SFM are appropriate with 11i v3 - and do you think the SFMProviders are just not good with highly threaded machines (mine is 32-threads).
RaghuM
Occasional Visitor

Re: cimprovagt burning CPU on rx6600


Try installing patches on C.04 and see if your problem disappears.
http://docs.hp.com/en/14729/sfm_ptch.htm

Have you contacted RC for support?

Raghu
Tom Haddad
Super Advisor

Re: cimprovagt burning CPU on rx6600

HI GXW,
I have an RX7640 running 11iv3. I had the high CPU condition with CIMPROVAGT in June this year. I too was able to stop the process (CIMSERVER -S). Support recommended that I upgrade WBEM Services to A.02.07.04, which I did. Also I am using SystemFaultManager C.05.00.06. Seems the WBEM Services upgrade resolved the issue.

I implemented HP Systems Insight Manager early this year which required product upgrades on my 11iv3 and 11iv2 HPUX managed nodes. Through this implementation, I learned more about CIMSERVER and other related processes (/opt/wbem...)