cancel
Showing results for 
Search instead for 
Did you mean: 

cimprovagt high % cpu

unixteamco-op
Occasional Visitor

cimprovagt high % cpu

Hi,

We have an issue on some of our servers where cimprovagt is using large amounts of cpu. I followed the recommendations to upgrade SFM, however I am no longer receiving events on the CMS since the upgrade.

The version of SFM that we have upgraded to is C.06.00.07.01 which is part of the DiagProdCollections bundle.

The servers in question are BL860c's running 11.31.

The steps I took were as follows:

Unsubscribe agent in SIM
Remove agent in SIM
Stop CIM on agent
Stop SFM on agent
Remove SFM on agent.
Install DiagProdCollection bundle which includes SFM on agent.
Restart SFM on agent
Restart CIM on agent.
Add node into SIM on CMS.
Subscribe node to WBEM events on CMS
Send test event using "send_test_event ia64_corehw"

Any help greatly appreciated.

Thanks
Simon
4 REPLIES
Fergus McLellan
Occasional Visitor

Re: cimprovagt high % cpu

Simon

Have you upgraded the other components associated with DiagProdCollection? I have had a number of issues with CIM processes which have been resolved by upgrading WBEMSvcs to A.02.09.

I've also got a case open with HP at the moment for a CIM/SAS related problem with 3000 cimprovagt ZOMBIE processes and kernel memory leak:
â A memory leak occurs in the cimprovagt process when the loaded provider reaches the value specified for the max_thread_proc parameter. Also, all subsequent pthread_create() calls fail.â

This is resolved in WBEMSvcs A.02.09.02 (release notes: http://docs.hp.com/en/B8465-90043/B8465-90043.pdf). You should also check the other associated components are up to date:
SysMgmtBASE B.00.02.04.07
EventMonitoring A.04.20.31.05

Make sure that you updated all of the components, not just SFM, when you installed the latest DiagProdCollection.

Cheers
Fergus
Kevin Bingham
Regular Advisor

Re: cimprovagt high % cpu

That link is proken, but I think this is now the correct one? http://docs.hp.com/en/B8465-90043/ch01s05.html
SoorajCleris
Honored Contributor

Re: cimprovagt high % cpu

Hi

==> " however I am no longer receiving events on the CMS since the upgrade."

Do you have any error message in swagent.log during intallaion/upgradation of SFM?

could you see the IPMI module?

kcmodule and ioscan??

Regards,
Sooraj

"UNIX is basically a simple operating system, but you have to be a genius to understand the simplicity" - Dennis Ritchie
SoorajCleris
Honored Contributor

Re: cimprovagt high % cpu

Did you mean you have installed complete diogonostic bundle

https://h20392.www2.hp.com/portal/swdepot/displayProductInfo.do?productNumber=DiagProdCollection

????
if no, you may do it.

Regards,
sooraj
"UNIX is basically a simple operating system, but you have to be a genius to understand the simplicity" - Dennis Ritchie