cancel
Showing results for 
Search instead for 
Did you mean: 

clock backward ?

 
OlivierDrouin
Occasional Visitor

clock backward ?

Hi gurus,
I'm kind of lost on this one. Suppose I issue `date` every second. This is what I get:

root@autogouverneur01:/boot# date
Tue Sep 18 11:24:30 EDT 2007
root@autogouverneur01:/boot# date
Tue Sep 18 11:24:30 EDT 2007
root@autogouverneur01:/boot# date
Tue Sep 18 11:24:31 EDT 2007
root@autogouverneur01:/boot# date
Tue Sep 18 11:24:33 EDT 2007
root@autogouverneur01:/boot# date
Tue Sep 18 11:24:34 EDT 2007
root@autogouverneur01:/boot# date
Tue Sep 18 11:24:30 EDT 2007
root@autogouverneur01:/boot# date
Tue Sep 18 11:24:31 EDT 2007
root@autogouverneur01:/boot# date
Tue Sep 18 11:24:31 EDT 2007
root@autogouverneur01:/boot# date
Tue Sep 18 11:24:32 EDT 2007
root@autogouverneur01:/boot# date
Tue Sep 18 11:24:33 EDT 2007

Its always +4 seconds -4 seconds and once in a while the system can go forward one more second.

This is a newly installed box, running for about a week. The hardware is not new though.

Some more infos:

root@hostname:/boot# uname -a
Linux "hostname" 2.6.15-28-386 #1 PREEMPT Wed Jul 18 22:50:32 UTC 2007 i686 GNU/Linux

root@hostname:/boot# uptime
11:25:55 up 3 days, 15:07, 2 users, load average: 1.77, 3.00, 2.32



root@hostname:/boot# cat /proc/interrupts
CPU0
0: 70562794 IO-APIC-edge timer
1: 735 IO-APIC-edge i8042
4: 1547 IO-APIC-edge serial
7: 0 IO-APIC-edge parport0
8: 4 IO-APIC-edge rtc
9: 1 IO-APIC-level acpi
14: 312227 IO-APIC-edge ide0
15: 5244779 IO-APIC-edge ide1
177: 0 IO-APIC-level uhci_hcd:usb3
185: 38190485 IO-APIC-level uhci_hcd:usb1, uhci_hcd:usb4, i915@pci:0000:00:02.0
193: 37 IO-APIC-level uhci_hcd:usb2
201: 4 IO-APIC-level ehci_hcd:usb5
209: 0 IO-APIC-level Intel ICH5
217: 553389 IO-APIC-level eth0
NMI: 0
LOC: 131310810
ERR: 0
MIS: 0


Somebody has any clue about what is going on?

Btw, there is no cron job for ntpdate or else...
3 REPLIES
Ivan Ferreira
Honored Contributor

Re: clock backward ?

Is it NTP running on your system, what do you have in /var/log/messages? What is your configuration in /etc/sysconfig/clock. Once I had a similar problem and setting UTC and ARC to false solved the problem, if I remember well.
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
OlivierDrouin
Occasional Visitor

Re: clock backward ?

Thanks,
ntp is not running. /var/log/messages doesnt show anything useful.

Even if I sync the hardware clock and soft clock with hwclock --systohc it starts to drift right away.

I think it's acpi I need to turn off but a reboot seems to have fixed the problem. I'll keep an eye on this system to see if it happens again.
OlivierDrouin
Occasional Visitor

Re: clock backward ?

A reboot solved the problem.

The system is responsive and the clock has not drifted in 5 hours uptime. Could Apic be the culprit?