cancel
Showing results for 
Search instead for 
Did you mean: 

cluster issue

whiz_kid911
Frequent Advisor

cluster issue

vg01 was part of another cluster, which was was deleted by executing cmdeleteconf and a new cluster was created with the below ascii file.

cmclconfig.ascii contents:
===============================================
CLUSTER_NAME PROD_DB
NODE_NAME prod_db
NETWORK_INTERFACE lan2
HEARTBEAT_IP 172.27.21.14
NETWORK_INTERFACE lan4
NETWORK_INTERFACE lan5
HEARTBEAT_IP 10.10.7.14
HEARTBEAT_INTERVAL 2000000
NODE_TIMEOUT 5000000
AUTO_START_TIMEOUT 600000000
NETWORK_POLLING_INTERVAL 2000000
VOLUME_GROUP /dev/vg01

Also a package was built successfully, however package doesnt run with below error log:


########### Node "prod_db": Starting package at Tue Dec 15 21:22:56 WAT 2009 ###########
Dec 15 21:22:56 - Node "prod_db": Activating volume group vg01 with exclusive option.
vgchange: Volume group "/dev/vg01" belongs to a different Cluster. Activation failed.
ERROR: Function activate_volume_group
ERROR: Failed to activate vg01
Dec 15 21:22:56 - Node "prod_db": Deactivating volume group vg01
vgchange: Volume group "vg01" has been successfully changed.

########### Node "prod_db": Package start failed at Tue Dec 15 21:22:56 WAT 2009 ###########

cmviewcl output given below:


CLUSTER STATUS
PROD_DB up

NODE STATUS STATE
prod_db up running

UNOWNED_PACKAGES

PACKAGE STATUS STATE AUTO_RUN NODE
NFS_SERVER_PKG down halted disabled unowned

I tried to take the vg out of the cluster config, though its performs "-c n ", vg activation fails as below:


prod_db:/etc/cmcluster/pkg_nfs#vgchange -a n vg01
vgchange: Volume group "vg01" has been successfully changed.
prod_db:/etc/cmcluster/pkg_nfs#vgchange -c n vg01
Performed Configuration change.
Volume group "vg01" has been successfully changed.
prod_db:/etc/cmcluster/pkg_nfs#vgchange -a y vg01
vgchange: Activation mode requested for the volume group "/dev/vg01" conflicts with configured mode.
prod_db:/etc/cmcluster/pkg_nfs#vgchange -a e vg01
vgchange: Volume group "/dev/vg01" belongs to a different Cluster. Activation failed.
prod_db:/etc/cmcluster/pkg_nfs#

has anyone seen this before ?
4 REPLIES
Rita C Workman
Honored Contributor

Re: cluster issue

hmmm...when we used to run a DR site using Continental Cluster, it seems to me we had to reset the cluster id. If memory serves me right we simply did:
vgchange -c n
vgchange -c y

So deactivate vgchange -a n and then try the above and see if that helps.

Rgrds,
Rita
Steven E. Protter
Exalted Contributor

Re: cluster issue

Shalom,

Also: Can you manually activate the volume group?

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
shanmuhanandam
Regular Advisor

Re: cluster issue

Hi,
i think the vg01 is already activated, can you check the vgdisplay -v vg01?

Regards,
Shanmugam.B
I am an HPE Employee
ANilW
Visitor

Re: cluster issue

hi,
in your logs : prod_db:/etc/cmcluster/pkg_nfs#vgchange -a y vg01
vgchange: Activation mode requested for the volume group "/dev/vg01" conflicts with configured mode.

It seems your VGs are not cluster awared.
try manualy vgchange -a n vgxx
vgchange -c y vgxx. and check for VG status
regards
Anil