cancel
Showing results for 
Search instead for 
Did you mean: 

cluster issue.

AVV
Super Advisor

cluster issue.

Hi,

I am very much new to Linux and facing a probel for a quorum disk. I will give a detailed explaination below.

Nodes: 2
RHEL 5.3
storages are assigned from MSA2000.
---
I created the cluster through graphical view using system-config-cluster. I added the nodes,ilo,resources and services to the cluster through this. At the first time itself, I gave the quorum disk (labled as Qdisk)at the first shot. Given the program as /sbin/vgdisplay so that it may get the value of 0 (as instructed on a doc.).

Now I ran the cluster through service cman start and service rgmanager start on both nodes. I could see all the services are up and running on primary node. I am even success in relocating the services from one node to another.All the way it works. Lastly, I tried to reboot the cluster node which holds the services and the same should come up on the alternative one. Here onwards , I am into trouble. As soon as the system goes down, services are shown "stopped" on the other node, after some moment, it just gives as "starting" but again goes down.Gives error as quorum votes or non quorantined. I believe that this may be because of the calculations given while configuring the quorum votes but I never gave it anywhere. Might be it taken the by default values. Can someone help me to configure the voting procedure with steps if it is related to that issue.

cman_tool status gives me the below output.

expected votes :2
Total Votes: 2
quorum :2

Waiting for the assistance from master minds. Thanks a lot.

5 REPLIES
Ivan Ferreira
Honored Contributor

Re: cluster issue.

Can you post the full output of cman_tool status and clustat?

Please see:

http://www.linuxdynasty.org/howto-setup-a-quorum-disk.html
http://magazine.redhat.com/2007/12/19/enhancing-cluster-quorum-with-qdisk/
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
AVV
Super Advisor

Re: cluster issue.

Hi Evan,

Thanks for the reply. Please help me on the below. Asked outputs are below

[root@localhost ~]# clustat
Cluster Status for CP_CLUSTER @ Sun Aug 30 11:40:37 2009
Member Status: Quorate

Member Name ID Status
------ ---- ---- ------
node1-xx-master 1 Online, Local, rgmanager
node2-yy-standby 2 Online, rgmanager
/dev/dm-6 0 Offline, Quorum Disk

Service Name Owner (Last) State
------- ---- ----- ------ -----
service:DP_CCG node1-xx-master started
service:DP_DROPCOPY node1-xx-master started
service:DP_HUB node1-xx-master started
service:DP_ORACLE node1-xx-master started
service:DP_UTM node1-xx-master started
service:DP_UTP_CNTRL node1-xx-master started
service:DP_UTP_TRADING node1-xx-master started
service:DP_XDP node1-xx-master started
[root@localhost ~]# cman_tool status
Version: 6.1.0
Config Version: 12
Cluster Name: PP_CLUSTER
Cluster Id: 11220
Cluster Member: Yes
Cluster Generation: 1708
Membership state: Cluster-Member
Nodes: 2
Expected votes: 2
Total votes: 2
Quorum: 2
Active subsystems: 9
Flags: Dirty
Ports Bound: 0 177
Node name: node1-xx-master
Node ID: 1
Multicast addresses: 239.192.43.0
Node addresses: 172.16.54.3
[root@localhost ~]#
Ivan Ferreira
Honored Contributor

Re: cluster issue.

Total votes should be 3, and there should be an output indicating "Quorum device votes: 1".

Have you updated the configuration on all nodes? Have you incremented the config_version

Check the output on both nodes, and also. Post your cluster.conf file and also, the messages that you get when you restart cman in /var/log/messages.

Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
Steven E. Protter
Exalted Contributor

Re: cluster issue.

Shalom,

Is that quorum disk really working?

/dev/dm-6 0 Offline, Quorum Disk

Maybe run a simple dd test make sure it is in a proper state.

Also, the ilo device has been very twitchy with me in the past and you might want to make sure the firmware there is up to date.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
AVV
Super Advisor

Re: cluster issue.

Thanks