System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

coda port (381) is not LISTEN

skt_skt
Honored Contributor

coda port (381) is not LISTEN


i have a problem one of the linux node communicationg to my OVPM server.

2.4.9-e.57smp
Red Hat Linux Advanced Server release 2.1AS (Pensacola)

it is a vmware guest server
# ps -ef|grep -i vmware
root 379 1 0 2007 ? 00:25:15 /usr/sbin/vmware-guestd --backgr

Not sure how to this port open. While port 383 (llbserver) is LISTEN state

tcp 0 0 0.0.0.0:383 0.0.0.0:* LISTEN

6 REPLIES
skt_skt
Honored Contributor

Re: coda port (381) is not LISTEN


#telnet adela133p 381
Trying 127.0.0.1...
telnet: connect to address 127.0.0.1: Connection refused

not sure if there a restriction going through 127.0.0.1?
Kevin Wright
Honored Contributor

Re: coda port (381) is not LISTEN

you may need to force coda to run on 381:
ovconfchg -ns coda.comm -set SERVER_PORT 381
ovc -restart

netstat -an |grep 381/telnet to 381 will confirm.
skt_skt
Honored Contributor

Re: coda port (381) is not LISTEN

i hope you meant the chnages on the server side.At the server side i am getting a connection refused.

telnet adedd61p 381
Trying...
telnet: Unable to connect to remote host: Connection refused

adedd61p:root [/opt/OV/bin] telnet adedd61p 383
Trying...
Connected to adedd61p.ami.alcoa.com.
Escape character is '^]'.

telnet> close
Connection closed.

adedd61p:root [/opt/OV/bin] netstat -an|grep LISTEN|egrep -i "383|381"
tcp 0 0 *.383 *.* LISTEN


But how my other clients are not reporting any problem like this and showing LISTEN state for both for 381 and 383?

Matti_Kurkela
Honored Contributor

Re: coda port (381) is not LISTEN

Use "netstat -anp" as root: it will allow you to see which processes are using the ports. Or use "lsof -i tcp:383" and "lsof -i tcp:381" to get the same information in another way.

Compare the results in different nodes, and you can identify the process that should be using the port 381 but isn't.

MK
MK
Kevin Wright
Honored Contributor

Re: coda port (381) is not LISTEN

run the ovconfchg command I previously posted to enable coda to run on 381
skt_skt
Honored Contributor

Re: coda port (381) is not LISTEN

i dont prefer to make change on the servser side for a single clinet. But i can try this later..