HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

configure linux for isocated IP.

 
avizen9
Esteemed Contributor

configure linux for isocated IP.

Hello,

I am having Redhat Enterprise Linux with two network Card, I have configured this linux as a router.
First network card connecting to my company public network port (146.223.xx.xx) and another connecting to windows 200 server.
This windows 2000 server doesn’t have any other network card. Only one network card which will get network cable via this linux machine.
My aim is whenever somebody will access this windows server it should go via this linux machine (which is secure),I had configured below files in linux machine.
/etc/dhcpd.conf
/etc/shorewall
/etc/sysconfig/network-scripts/ifcfg-eth0
And all other require files.
All configuration has done I am able to access this windows server by remote-desktop (typing linux machine hostname).
Windows server able to get 192.xxx.xx.xx isolated IP address through linux machine. As I had configured /etc/dhcpd.conf
Problem is my windows server can not talk with my company public network (146.223.xx.xx), even I can’t ping. However I am able to do internet surfing from windows server so it mean winnows server talk outside, but can not to company public network (146.223.xx.xx).
I believe I missed somewhere a minor settings but don’t know what,

Appreciated your help here, please reply me for any help surely will assign point and full point for correct answer.
6 REPLIES
avizen9
Esteemed Contributor

Re: configure linux for isocated IP.

anyone any help here? appriciate it, thanks
Alexander Chuzhoy
Honored Contributor

Re: configure linux for isocated IP.

You should add a route in your public network's router.
If someone from your public network wants to go to the IP of this Windows server, then it should go via your Linux station.
avizen9
Esteemed Contributor

Re: configure linux for isocated IP.

HI,as i mentioned before,
i am able to access this server through my public network, but from this server i cant access my company ip. so its one way, i believe we need to modify configuration file but which file and what need to modify i dont know,

Alexander Chuzhoy
Honored Contributor

Re: configure linux for isocated IP.

Hmm,
could you please post the following:
1. routing table of the windows server and linux router along with the IP of the Windows server.
2. The output from `iptables -l` on your linux router.
avizen9
Esteemed Contributor

Re: configure linux for isocated IP.

here is attached all info, pls let me know,


welcome all other suggesion, thanks,
smatador
Honored Contributor

Re: configure linux for isocated IP.

Hi,
First of all, stop the firewall and made the test without it. After you could enable and put some rules.
If I understand, the linux box is configure like a router, so the windows have to route to the linux IP { it seem correct because dhcp server = gateway }. After that, the linux have to route to the public network.
What about the routing table of the linux box?
Do you play with tracert on the windows, where it's stopping?