HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

couldn't update 11.23 SysfaultMgmt to the latest verson

 
xianjun_1
Advisor

couldn't update 11.23 SysfaultMgmt to the latest verson

My customer have about 20 11.23 systems. when I tried to update SysFaultMgmt to the latest b.07.01,it show me following erros after intalling the depot:
Registering SFMProvidersHPOnlyIaR.mof with namespace root/PG_InterOp
/usr/lib/hpux64/dld.so: Unable to find library 'libgs.1'.
CIM_ERR_FAILED: PGS04201: PROVIDER FMDProvider IN FILE /opt/wbem/providers/lib/
libsfmproviders.so CANNOT LOAD LIBRARY. ERROR: Unable to find library 'libgs.1'
..
CIM_ERR_FAILED: PGS04201: PROVIDER ChassisProvider IN FILE /opt/wbem/providers/
lib/libsfmproviders.so CANNOT LOAD LIBRARY. ERROR: Unable to find library 'libg
s.1'..
CIM_ERR_FAILED: PGS04201: PROVIDER FMDProvider IN FILE /opt/wbem/providers/lib/
libsfmproviders.so CANNOT LOAD LIBRARY. ERROR: Unable to find library 'libgs.1'
..
Did I miss something?Thanks
2 REPLIES
James R. Ferguson
Acclaimed Contributor

Re: couldn't update 11.23 SysfaultMgmt to the latest verson

Shinji Teragaito_1
Respected Contributor

Re: couldn't update 11.23 SysfaultMgmt to the latest verson

When you upgraded SysFaultMgmt, did you encounter any error ?
Can you find any error messages in /var/adm/sw/swagent.log ?

# swlist -l file SysFaultMgmt | grep libgs
SysFaultMgmt.SFM-CORE.GS_COREIA: /opt/sfm/lib/libgs.1
# ldd /opt/wbem/providers/lib/libsfmproviders.so | grep libgs
libgs.1 => /opt/sfm/lib/libgs.1
#

I wonder the file permission for libgs.1 is "-r-xr-xr-x" (555).

Please doublecheck it.