cancel
Showing results for 
Search instead for 
Did you mean: 

cpqacuxe can not start

 
SOLVED
Go to solution
Yayat
Frequent Advisor

cpqacuxe can not start

Hi there,

Please help to this problem !

[root@localhost ~]# rpm -qa|grep compat
java-1.4.2-gcj-compat-devel-1.4.2.0-40jpp.112
compat-libf2c-34-3.4.6-4
compat-gcc-34-g77-3.4.6-4
compat-libstdc++-296-2.96-138
java-1.4.2-gcj-compat-javadoc-1.4.2.0-40jpp.112
compat-gcc-34-c++-3.4.6-4
compat-libstdc++-33-3.2.3-61
java-1.4.2-gcj-compat-1.4.2.0-40jpp.112
compat-gcc-32-3.2.3-47.3
compat-glibc-headers-2.3.4-2.26
compat-libgcc-296-2.96-138
java-1.4.2-gcj-compat-src-1.4.2.0-40jpp.112
compat-gcc-32-c++-3.2.3-47.3
compat-db-4.2.52-5.1
compat-gcc-34-3.4.6-4
compat-glibc-2.3.4-2.26
[root@localhost ~]# cpqacuxe
ps: error while loading shared libraries: libdl.so.2: cannot open shared object file: No such file or directory
grep: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory
Can not run because of HP System Management Homepage is not started or uninstalled.
Please try to use /etc/init.d/hpsmhd start to start it.
[root@localhost ~]# cpqacuxe -R
ps: error while loading shared libraries: libdl.so.2: cannot open shared object file: No such file or directory
grep: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory
Can not run because of HP System Management Homepage is not started or uninstalled.
Please try to use /etc/init.d/hpsmhd start to start it.
[root@localhost ~]# service hpsmh status
hpsmh: unrecognized service
[root@localhost ~]# service hpsmhd status
hpsmhd (pid 2681 2637) is running...
[root@localhost ~]#

Thank you in advance.

Regard,

Yayat
17 REPLIES
Matti_Kurkela
Honored Contributor

Re: cpqacuxe can not start

The "cpqacuxe" command is a script, and it tries to run "ps" and "grep" commands, which both seem to fail with library errors... if that was true, your system would have some serious trouble.

Can you run "ps -ef | grep hpsmhd" manually with no problems? (Probably yes.)

What's the name and version of the Linux distribution you're using? RedHat, SuSE or something else?

What's the hardware architecture of this machine? IA64 (Itanium), 64-bit x86_64 (aka AMD64) or the plain 32-bit ix86? What does "uname -m" report?

If this is IA64, have you installed the ix86 emulation layer? At least on RHEL 5, it comes on a separate CD and must be installed as a separate operation after the OS installation.

MK
MK
Steven E. Protter
Exalted Contributor

Re: cpqacuxe can not start

Shalom,

Re-install the PSP and install the dependencies.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Yayat
Frequent Advisor

Re: cpqacuxe can not start

Hi all,
I installed linux on my ML350 G5 with SA E200i. Actually I installed CentOS 5 distro which is Red Hat clone, then I modified the redhat-release to be able install HP PSP. Note that I install cpqacuxe trough HP PSP and I can use the SMH without any error in this machine, the storage status is well monitored in there.
Here are the sysinfo that maybe help.

[root@devel ~]# uname -r
2.6.18-53.1.14.el5
[root@devel ~]# uname -m
i686
[root@devel ~]# rpm -qa|grep libtdc
[root@devel ~]# rpm -qa|grep libstdc
compat-libstdc++-296-2.96-138
libstdc++-4.1.2-14.el5
compat-libstdc++-33-3.2.3-61
[root@devel ~]# ps -ef | grep hpsmhd
root 2696 1 0 09:07 ? 00:00:00 /opt/hp/hpsmh/sbin/hpsmhd -DSSL -f /opt/hp/hpsmh/conf/smhpd.conf
hpsmh 2710 2696 0 09:07 ? 00:00:00 /opt/hp/hpsmh/sbin/hpsmhd -DSSL -f /opt/hp/hpsmh/conf/smhpd.conf
root 7969 5601 0 09:18 pts/1 00:00:00 grep hpsmhd
[root@devel ~]# cat /etc/redhat-release
Red Hat Enterprise Linux Server release 5
[root@devel ~]#

What are other dependencies ?
Thank you all.

Yayat
Colin Topliss
Esteemed Contributor

Re: cpqacuxe can not start

Hi,

The libraries mentioned in your posting are part of glibc...

[root@rhsystest2 /]# rpm -qf /lib/libc.so.6
glibc-2.3.4-2.25
[root@rhsystest2 /]# rpm -qf /lib/libdl.so.2
glibc-2.3.4-2.25

...obviously this is on my system, so the versions might be different.

[root@rhsystest2 install]# ldd /bin/ps
libproc-3.2.3.so => /lib/libproc-3.2.3.so (0x00271000)
libc.so.6 => /lib/tls/libc.so.6 (0x00144000)
/lib/ld-linux.so.2 (0x00126000)

shows the linked libraries. Maybe your environment is not set right? Did you play aorund with LD_LIBRARY_PATH or SHLIB_PATH?

The failing section of code isn't doing anything special other than setting a variable depending on whether hpsmh is running or not.

Colin.
Yayat
Frequent Advisor

Re: cpqacuxe can not start

Hi all,

I had installed all dependencies of HP PSP and then reinstall PSP with no error.And I had installed my Linux too before installing PSP. But unfortunately I still got the same error like before. And I navigate to the system files and having that libdl.so.2 and libc.so.6 does exists there.

As a note, I am newbie with linux, so please write a post as I was a newbie.Thank you very much.


Yayat
Yayat
Frequent Advisor

Re: cpqacuxe can not start

This is the output of command you mentioned.

[root@devel CentOS]# rpm -qf /lib/libc.so.6
glibc-2.5-18
[root@devel CentOS]# rpm -qf /lib/libdl.so.2
glibc-2.5-18
[root@devel CentOS]# ps -ef|grep hpsmhd
root 18252 1 0 14:01 ? 00:00:00 /opt/hp/hpsmh/sbin/hpsmhd -DSSL -f /opt/hp/hpsmh/conf/smhpd.conf
hpsmh 18256 18252 0 14:01 ? 00:00:00 /opt/hp/hpsmh/sbin/hpsmhd -DSSL -f /opt/hp/hpsmh/conf/smhpd.conf
root 25534 3222 0 14:24 pts/2 00:00:00 grep hpsmhd
[root@devel CentOS]# ldd /bin/ps
linux-gate.so.1 => (0x00d50000)
libproc-3.2.7.so => /lib/libproc-3.2.7.so (0x0073b000)
libdl.so.2 => /lib/libdl.so.2 (0x00735000)
libc.so.6 => /lib/libc.so.6 (0x005f3000)
/lib/ld-linux.so.2 (0x005d1000)
[root@devel CentOS]#

Thanks
Colin Topliss
Esteemed Contributor

Re: cpqacuxe can not start

...and you are definitely running a 64bit version of Centos AND installing the 64bit version of the PSP?

I'm still thinking its an issue with the environment (perhaps the path is being changed in the script - I haven't had chance to log in to look myself).
Siert Zijl
Advisor

Re: cpqacuxe can not start

Usually this error occurs when you install a 32-bits PSP on a 64-bits OS. Please, verify.

If that isn't the problem, it might be a missing RPM (rpm requirements are listed in the PSP documentation). Verify the requirements using the following command:

rpm -qa --queryformat "%{NAME}-%{VERSION}-%{RELEASE} (%{ARCH})\n" 'compat*'

Then make sure both x86 and x86_64 requirements are installed.
Linux system administrator
Yayat
Frequent Advisor

Re: cpqacuxe can not start

I installed Centos 5 on ML350 G5, and I installed PSP trough Smart Start CD that I think it can select what's suite for my OS version. Then please tell me how to verify my OS 32 or 64 bit ? Am I right that ML350 G5 is 32bit machine ?
Rvb
Occasional Visitor
Solution

Re: cpqacuxe can not start

Yayat,
modify /usr/sbin/cpqacuxe.sh script - set VER=`grep Tikanga $RHREL` without if ...fi .
All the best,
Sergey


Yayat
Frequent Advisor

Re: cpqacuxe can not start

Hi Rvb,

Please tell me which section need to remove.

# need to see if this is a RHEL5 box
RHREL="/etc/redhat-release"
if [ -z "$VER" ] && [ -f "$RHREL" ]
then
VER=`grep Tikanga $RHREL`
fi


Thank you very much.
Rvb
Occasional Visitor

Re: cpqacuxe can not start

...
ACUXE_BIN_INSTALLATION_DIR=/opt/compaq/cpqacuxe/bld/
export ACUXE_BIN_INSTALLATION_DIR
LD_LIBRARY_PATH=$ACUXE_BIN_INSTALLATION_DIR
export LD_LIBRARY_PATH
IM_CFGFILE_PATH=$ACUXE_BIN_INSTALLATION_DIR
export IM_CFGFILE_PATH
ACUXE_LOCK_FILES_DIR=/opt/compaq/cpqacuxe/bld/locks/
export ACUXE_LOCK_FILES_DIR

#
# need to see if this is a RHEL5 box
RHREL="/etc/redhat-release"
VER=`grep Tikanga $RHREL`

ACUXE_PASS_FAILED=0
....
Yayat
Frequent Advisor

Re: cpqacuxe can not start

Hi Sergey,

I mean I want to know if my OS was 32/64 bit version. So I can download the right version of software for the OS. Thanks.
Yayat
Frequent Advisor

Re: cpqacuxe can not start

Ok I should use uname -a to determine my OS architecture. Sorry, newbie's fool.
habibalby
Frequent Advisor

Re: cpqacuxe can not start

Hello, could you pleas tell me how you have solve your problem?

I wanted to run the ACU to configure the MSA1000 while it's connected to the ESX Servers. When i run the cpqacuze with -R switch, i was able to install it but the Remote Management didn't start, due to

[root@nbbdevesx03 cpqacuxe]# cpqacuxe -R
Can not run because of HP System Management Homepage is not started or uninstalled.

Can anyone help?

Yayat
Frequent Advisor

Re: cpqacuxe can not start

Hi Habibalby,

First, ensure your snmp service is running for the HP SMH to work.
#service snmpd status
Verify that kernel, kernel-headers, and kernel-devel have the same version, eg:2.6.18-53.el5
#rpm -qa|grep kernel
Install HP SMH using HP LDU from smart start CD. Mount smart start CD ROM to eg:/mnt/cdrom/
#cd /mnt/cdrom/compaq/csp/linux
#./install.sh
Follow the wizard and wait till it finish.

Verify you have array controller driver isntalled.

#rpm -qa|grep cpq_cciss
it should show something like cpq_cciss-2.6.x.x

Verify the driver modul is loaded.

#lsmod
it should show cciss module listed there.

If not you should remove the cpq_cciss first.

#rpm -e --noscripts cpq_cciss
Verify that your redhat-release is supported OS.
#cat /etc/redhat-release
If your OS is Red Hat or CentOS it should be like "Red Hat Enterprise Linux Server bla bla"
In my case my OS is CentOS 5.1, so I have to edit /etc/redhat-release to be "Red Hat Enterprise Linux Server release 5.1 (Tikanga)". Centos is not supported OS but it is Red Hat Clone.
#vi /etc/redhat-release

Download the cpq_cciss package that support your running kernel. Dont forget to download the .txt file for that package so you can read what kernel are supported by that cpq_cciss version.
Install the cpq_cciss driver

#rpm -ivh cpq_cciss....
If you get no error then it should work.
Run the cpqacuxe that isntalled by HP LDU in earlier step.

#cpqacuxe

Login to your HP SMH, click ACU link in Storage Group.

Done, good luck

Yayat
Yayat
Frequent Advisor

Re: cpqacuxe can not start

It has been solved, thank you for all reply.