HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

depothelper gcc-4.2.3 install failed

 
funkenflug68
Occasional Advisor

depothelper gcc-4.2.3 install failed

Hello all,

I tried installing gcc-4.2.3 using the tool depothelper. After installing some prerequisites it downloaded gcc-4.2.3 but then failed. Its output was Package-version gcc-4.2.3, Comment Requested, Download Using cache, Install FAILED. What can I do to find out why the download failed?

Thanks in advance,

Jörg

3 REPLIES
funkenflug68
Occasional Advisor

Re: depothelper gcc-4.2.3 install failed

Hello all,

sorry, but I found my mistake: depothelper wanted to install the software in /usr/local, but I had not enough space left on that device. After throwing away some old software the install succeded. I'm curious now if the compiler is able to build a shared library with ld +init, i.e. if the bundle also contained the updated ld.

regards,

Jörg

funkenflug68
Occasional Advisor

Re: depothelper gcc-4.2.3 install failed

Hi again,

the gcc-4.2.3 bundle does __NOT__ contain the linker patch :-(, each build with it fails with an error due to +init being passed to ld :-(

Could someone please send me a patch to update ld?

regards,

Jörg

Re: depothelper gcc-4.2.3 install failed

> Could someone please send me a patch to update ld?

 

As mentioned in the reply to your other post, you need a support contract:

 https://community.hpe.com/t5/System-Administration/HP-UX-Patch-Download/m-p/7002398