cancel
Showing results for 
Search instead for 
Did you mean: 

/dev/lan0 mounting

Sathyanarayanan Velu
Occasional Visitor

/dev/lan0 mounting

Can someone help me how to create /dev/lan0 in Itanium Server (HPUX11.31) using

# insf -e
# insf -C lan
# insf -C lan -I 0

(The above command is not creating the device, something wrong in the argument?)

In HPUX11.11 I could find /dev/lan0 by default. But in HPUX11.31 there is no /dev/lan0 by default. I want to create this mount point by myself. Please let me know the steps to create.

For some more info on the Hardware.


HPUX11.31

slbps0,sys,root # ioscan -funC lan
Class I H/W Path Driver S/W State H/W Type Description
=========================================================================
lan 0 0/0/0/28/0/0/0 iether CLAIMED INTERFACE HP AH395-60001 PCIe 1000Base-T
lan 1 0/0/0/28/0/0/1 iether CLAIMED INTERFACE HP AH395-60001 PCIe 1000Base-T
lan 2 0/0/0/28/2/0/0 iether CLAIMED INTERFACE HP AH395-60001 PCIe 1000Base-T
lan 3 0/0/0/28/2/0/1 iether CLAIMED INTERFACE HP AH395-60001 PCIe 1000Base-T


HPUX11.11

chola,sys,root # ioscan -funC lan
Class I H/W Path Driver S/W State H/W Type Description
===================================================================
lan 0 0/1/2/0 igelan CLAIMED INTERFACE HP PCI 1000Base-T Core

6 REPLIES
Shibin_2
Honored Contributor

Re: /dev/lan0 mounting

Your lan must be pointed to /dev/dlpi ( e.g. below )

/dev/lan -> /dev/dlpi

All your networking interfaces must be showing as /dev/dlpi* .

Without /dev/lan do you have any issues ? How about nwmgr output shows ?
Regards
Shibin
Andrew Rutter
Honored Contributor

Re: /dev/lan0 mounting

hi,

if the dev files are not there you would create them with the mknod command

#man mknod

but as said, /dev/lan and /dev/snap should be linked to /dev/dlpi for 11.31.

what does
#ls -l /dev/lan
show

see this guide for more info on configuring lan devices in 11.31

http://bizsupport1.austin.hp.com/bc/docs/support/SupportManual/c02037128/c02037128.pdf

but what does lanscan show? or nwmgr --get commands
#lanscan
#nwmgr --get

the ioscan output looks fine

Andy
Sathyanarayanan Velu
Occasional Visitor

Re: /dev/lan0 mounting

The lanscan and nwmgr --get looks OK (see result pasted). We are configuring X25 link from HPUX11.31. Our application is expecting /dev/lan0 to write the messages. So it is mandatory to have /dev/lan0. Now I donot know how to create /dev/lan0. Can this be created using mknode or insf?.

slbps0,sys,root # pwd
/dev
slbps0,sys,root # ls -al | grep dlp
crw-rw-rw- 1 root sys 72 0x000077 Dec 16 10:24 dlpi
crw-rw-rw- 1 root sys 119 0x000000 Dec 16 10:24 dlpi0
crw-rw-rw- 1 root sys 119 0x000001 Dec 16 10:24 dlpi1
crw-rw-rw- 1 root sys 119 0x000002 Dec 16 10:24 dlpi2
crw-rw-rw- 1 root sys 119 0x000003 Dec 16 10:24 dlpi3
crw-rw-rw- 1 root sys 119 0x000004 Dec 16 10:24 dlpi4
lrwxr-xr-x 1 root sys 9 May 8 20:38 lan -> /dev/dlpi
lrwxr-xr-x 1 root sys 9 May 8 20:38 snap -> /dev/dlpi
slbps0,sys,root # lanscan
Hardware Station Crd Hdw Net-Interface NM MAC HP-DLPI DLPI
Path Address In# State NamePPA ID Type Support Mjr#
0/0/0/28/0/0/0 0x00237D440FFC 0 UP lan0 snap0 1 ETHER Yes 119
0/0/0/28/0/0/1 0x00237D440FFD 1 UP lan1 snap1 2 ETHER Yes 119
0/0/0/28/2/0/0 0x00237D441FAC 2 UP lan2 snap2 3 ETHER Yes 119
0/0/0/28/2/0/1 0x00237D441FAD 3 UP lan3 snap3 4 ETHER Yes 119
LinkAgg0 0x000000000000 900 DOWN lan900 snap900 6 ETHER Yes 119
LinkAgg1 0x000000000000 901 DOWN lan901 snap901 7 ETHER Yes 119
LinkAgg2 0x000000000000 902 DOWN lan902 snap902 8 ETHER Yes 119
LinkAgg3 0x000000000000 903 DOWN lan903 snap903 9 ETHER Yes 119
LinkAgg4 0x000000000000 904 DOWN lan904 snap904 10 ETHER Yes 119
slbps0,sys,root # nwmgr --get

Name/ Interface Station Sub- Interface Related
ClassInstance State Address system Type Interface
============== ========= ============== ======== ============== =========
lan0 UP 0x00237D440FFC iether 1000Base-T
lan1 UP 0x00237D440FFD iether 1000Base-T
lan2 DOWN 0x00237D441FAC iether 1000Base-T
lan3 DOWN 0x00237D441FAD iether 1000Base-T
lan900 DOWN 0x000000000000 hp_apa hp_apa
lan901 DOWN 0x000000000000 hp_apa hp_apa
lan902 DOWN 0x000000000000 hp_apa hp_apa
lan903 DOWN 0x000000000000 hp_apa hp_apa
lan904 DOWN 0x000000000000 hp_apa hp_apa
slbps0,sys,root #
slbps0,sys,root #
slbps0,sys,root # ls -al | grep snap
lrwxr-xr-x 1 root sys 9 May 8 20:38 snap -> /dev/dlpi
slbps0,sys,root # pwd
/dev
slbps0,sys,root # ifconfig lan0
lan0: flags=1843
inet 149.204.125.197 netmask ffffff00 broadcast 149.204.125.255
slbps0,sys,root # ifconfig lan1
ifconfig: no such interface
Matti_Kurkela
Honored Contributor

Re: /dev/lan0 mounting

If your program requires /dev/lan0, it uses a very old API: /dev/lan0 -style devices were used by the LLA/9000 product API, which was obsoleted after the HP-UX 10.0 release. At least since 1994, HP has been recommending the use of DLPI instead of LLA.

Apparently in HP-UX 11.11, there was backward compatibility for the old LLA interface, but in 11.31, the old interface is completely gone and cannot be used anymore: the /dev/lan* devices don't exist and cannot be created. The newer DLPI must be used instead.

Unfortunately, DLPI is not fully compatible with LLA: to make a program use DLPI instead of LLA, the program must be modified.

You should look at the LLA to DLPI migration guide (it seems to still be available in old docs.hp.com!):
http://docs.hp.com/en/98194-90053/index.html

MK
MK
rick jones
Honored Contributor

Re: /dev/lan0 mounting

Matti is correct - vestiges of LLA remained in 11.11 at the request of the workstations group even after years of telling everyone who would listen to migrate to DLPI, to allow crufty old licensing code to retrieve MAC addresses.

Anything written since, oh, about 1995 or 1996 should have used DLPI. I believe that DLPI was present by default in 10.20. I just cannot recall if 10.20 shipped in '95 or '96.
there is no rest for the wicked yet the virtuous have no pillows
Sathyanarayanan Velu
Occasional Visitor

Re: /dev/lan0 mounting

Thanks Matti and Rick. Thats exactly my problem. In HPUX11.11 the backward compatibility was there hence we were using LLA. Now its the time for us to Migrate to DLPI. I will contact you incase of issues during migration.

Thanks again.

Regards
Sathya