cancel
Showing results for 
Search instead for 
Did you mean: 

diagmond: Lack of Resources

Brian A. Scurlock_1
Frequent Advisor

diagmond: Lack of Resources

when I attempt to start diagmond, it dies isnstantly and I get the following entries in syslog:
Jul 22 10:05:55 MyServer diagmond[22504]: started
Jul 22 10:05:55 MyServer diagmond[22504]: Exit due to lack of resources

I got a couple of hits on this when searching the forums but no solutions. CPU Memory and Disk look normal as well as shared memory. The box has been up for almost 16 months straight though but I am not anxious to schedule a reboot just to fix this if another fix is available.

Thanks!!
-Brian
You can do anything you set your mind to when you have vision, determination, and an endless supply of expendable labor.
2 REPLIES
Duncan Edmonstone
Honored Contributor

Re: diagmond: Lack of Resources

Brian,

You might want to check how many semaphores you have available... do you have glance? if so:

glance -t

and see if you rae running out of resources somewhere (the only reference I can find to the error you mention is for semaphores)

HTH

Duncan

HTH

Duncan
Brian A. Scurlock_1
Frequent Advisor

Re: diagmond: Lack of Resources


Semaphore Table (semmni)
System Table
Available Used Utilization High%(%) 1024 838 82 82

Doesn't look like there is a problem...but I'm wondering if the old version kept some shared memory segments tied up. THis seemed to start when I upgraded to A.63 which isn't supposed to require a reboot.
You can do anything you set your mind to when you have vision, determination, and an endless supply of expendable labor.