System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

drd runcmd says root doesn't have enough permissions

SOLVED
Go to solution
mwarchut
Advisor

drd runcmd says root doesn't have enough permissions

I am preparing some RX8640 systems for an OS upgrade this weekend. When I tried to run 'drd runcmd swlist' or 'drd runcmd update-ux ....' it says I don't have permission yet I am logged in as root. Anyone seen this before?

RWOrac02:/# drd runcmd swlist

======= 06/03/10 14:40:06 PDT BEGIN Executing Command On Inactive System Image (user=root) (jobid=RWOrac02)

* Checking for Valid Inactive System Image
* Analyzing Command To Be Run On Inactive System Image
* Locating Inactive System Image
* Accessing Inactive System Image for Command Execution
* Setting Up Environment For Command Execution
* Executing Command On Inactive System Image
* Executing command: "/usr/sbin/swlist"
ERROR: Permission is denied for the current operation. There is no
entry for user id 0 in the user database. Check /etc/passwd
and/or the NIS user database.
ERROR: Could not initialize security. This process does not have
super-user privilege.
ERROR: Command executed on inactive system image returned an error
- The command "/usr/sbin/swlist" failed.
* Executing Command On Inactive System Image failed with 1 error.
* Cleaning Up After Command Execution On Inactive System Image

======= 06/03/10 14:40:33 PDT END Executing Command On Inactive System Image failed with 1 error. (user=root) (jobid=RWOrac02)
11 REPLIES
Patrick Wallek
Honored Contributor

Re: drd runcmd says root doesn't have enough permissions

This error is very disconcerting:

ERROR: Permission is denied for the current operation. There is no entry for user id 0 in the user database. Check /etc/passwd and/or the NIS user database.

Have you checked your /etc/passwd file? Is it correct?

Are you using anything like NIS, NIS+, or LDAP?
mwarchut
Advisor

Re: drd runcmd says root doesn't have enough permissions

We don't use any central auth on these boxes. Just the local /etc/passwd. I checked the local passwd file and all looks to be in order so I am a bit lost here. I think it may be almost time to open a ticket with HP.
Bob E Campbell
Honored Contributor

Re: drd runcmd says root doesn't have enough permissions

Check that root is defined in the local password file on the top line with something that looks like:

root:stuffHere:0:3:moreStuffHere...

After that what do you see returned from the commands "id" and "swlist"?
mwarchut
Advisor

Re: drd runcmd says root doesn't have enough permissions

as root I can run swlist with no issue.. It's only after making it part of the drd runcmd that it fails.

here is my root entry minus the password.

root:XXXXXXXXXXX:0:3::/:/usr/bin/sh

id returns fine

RWOrac02\:/# id
uid=0(root) gid=3(sys) groups=0(root),1(other),2(bin),4(adm),5(daemon),6(mail),7(lp),20(users)


Judy Wathen
Advisor

Re: drd runcmd says root doesn't have enough permissions

Did you see the original error when running "drd runcmd update-ux..." rather than "drd runcmd swlist"? If you still have the errors from that run, can you post them?

Also, can you run "bdf" to see if the clone is still partly mounted, nad
"ps -ef | grep sw" and "ps -ef | grep fsdaemon" to see if multiple swagentd processes or multiple fsdaemon processes are running?

Thanks,
Judy
mwarchut
Advisor

Re: drd runcmd says root doesn't have enough permissions

I do.. I keep a really big buffer in my terminal..

RWOrac02\:/# drd runcmd update-ux -s rwhpcab1:/var/11v3i/march-2010

======= 06/03/10 14:03:00 PDT BEGIN Executing Command On Inactive System Image (user=root) (jobid=RWOrac02)

* Checking for Valid Inactive System Image
* Analyzing Command To Be Run On Inactive System Image
* Locating Inactive System Image
* Accessing Inactive System Image for Command Execution
* Setting Up Environment For Command Execution
* Executing Command On Inactive System Image
* Using unsafe patch list version 20080324
* Starting swagentd for drd runcmd
* User supplied command: "/usr/sbin/update-ux -s rwhpcab1:/var/11v3i/march-2010"
* Executing command: "/opt/swm/bin/swmoeupdate -s rwhpcab1:/var/11v3i/march-2010"

======= 06/03/10 14:03:20 PDT BEGIN Operating Environment Update (user=root) (jobid=000005)

* Reading Target System's Installed Product Database (IPD)
* Target IPD: RWOrac02
* Reading Source Depot(s)
* Source depot: rwhpcab1:/var/11v3i/march-2010
* Choosing Operating Environment
* The chosen operating environment (OE) is: "HPUX11i-HA-OE".
NOTE: Loading *temporary* update tools that do not affect the running system and will be removed when the OE update is finished

* Analyzing OE Update Tools To Be Installed
* Analysis Summary
- Reboot needed: No
- Kernel build needed: No
- Number of check scripts run: 12 (0 excluded, 0 failed)
- Install: 20 filesets
* Loading OE Update Tools
* Installing fileset "SW-GETTOOLS.PRE-UPDATE,r=B.11.31.1003" (1 of 20).
* Installing fileset "SW-GETTOOLS.SD-SUPPORT,r=B.11.31.1003" (2 of 20).
* Installing fileset "SW-GETTOOLS.SD2-SUPPORT,r=B.11.31.1003" (3 of 20).
* Installing fileset "SWMTRANS.SWMT-ENG-A-HELP,r=A.3.5.1.186" (4 of 20).
* Installing fileset "SWMTRANS.SWMT-ENG-A-MAN,r=A.3.5.1.186" (5 of 20).
* Installing fileset "SWMTRANS.SWMT-JPN-E-HELP,r=A.3.5.1.186" (6 of 20).
* Installing fileset "SWMTRANS.SWMT-JPN-E-MAN,r=A.3.5.1.186" (7 of 20).
* Installing fileset "SWMTRANS.SWMT-JPN-S-HELP,r=A.3.5.1.186" (8 of 20).
* Installing fileset "SWMTRANS.SWMT-JPN-S-MAN,r=A.3.5.1.186" (9 of 20).
* Installing fileset "SWMTRANS.SWMT-RUN,r=A.3.5.1.186" (10 of 20).
* Installing fileset "Update-UX.SD-AGENT,r=B.11.31.1003.346" (11 of 20).
* Installing fileset "Update-UX.SD-CMDS,r=B.11.31.1003.346" (12 of 20).
* Installing fileset "Update-UX.SD-FRE-I-MSG,r=B.11.31.1003.346" (13 of 20).
* Installing fileset "Update-UX.SD-GER-I-MSG,r=B.11.31.1003.346" (14 of 20).
* Installing fileset "Update-UX.SD-JPN-E-MSG,r=B.11.31.1003.346" (15 of 20).
* Installing fileset "Update-UX.SD-JPN-S-MSG,r=B.11.31.1003.346" (16 of 20).
* Installing fileset "Update-UX.SD-KOR-E-MSG,r=B.11.31.1003.346" (17 of 20).
* Installing fileset "Update-UX.SD-TCH-B-MSG,r=B.11.31.1003.346" (18 of 20).
* Installing fileset "Update-UX.SD-TCH-H-MSG,r=B.11.31.1003.346" (19 of 20).
* Installing fileset "Update-UX.UUX2-OS-LIBS,r=B.11.31.1003.346" (20 of 20).
* Configuring OE Update Tools
ERROR: Unable to determine the status of the external Software Distributor command (pid: 29203): No child processes (errno=10).
NOTE: Loading *temporary* update tools that do not affect the running system and will be removed when the OE update is finished
failed with 1 error.
* Removing Temporary Update Tools
ERROR: Permission is denied for the current operation. There is no
entry for user id 0 in the user database. Check /etc/passwd
and/or the NIS user database.
ERROR: Could not initialize security. This process does not have
super-user privilege.

======= 06/03/10 14:04:28 PDT END Operating Environment Update failed with 3 errors. (user=root) (jobid=000005)

* Stopping swagentd for drd runcmd
ERROR: You must be superuser to run this command.
ERROR: Cannot stop swagentd for drd runcmd. For more information,
refer to /var/adm/sw/swagentd.log on the inactive system
image.
ERROR: Command executed on inactive system image returned an error
- One or more postcommands for /usr/sbin/update-ux failed.
- The command "/opt/swm/bin/swmoeupdate -s rwhpcab1:/var/11v3i/march-2010" failed.
- The postcommand "/opt/drd/wrappers/stop_swagentd" fails with the return code "1".
* Executing Command On Inactive System Image failed with 1 error.
* Cleaning Up After Command Execution On Inactive System Image
ERROR: Unmounting the file system fails.
- Unmounting the clone image fails.
- The "umount" command returned "1". The "sync" command returned "0". The error messages produced are the following: "umount: cannot unmount /dev/drd00/lvol8 : Device busy
umount: return error 1.
"
* Cleaning Up After Command Execution On Inactive System Image failed with 1 error.

======= 06/03/10 14:04:32 PDT END Executing Command On Inactive System Image failed with 2 errors. (user=root) (jobid=RWOrac02)

mwarchut
Advisor

Re: drd runcmd says root doesn't have enough permissions

its not currently mounted.. There is one fsdaemon and one swagentd running and that is all.

Judy Wathen
Advisor

Re: drd runcmd says root doesn't have enough permissions

I think you may be hitting a problem documented with a workaround in the DRD release notes.

Can you check
http://www.hp.com/go/drd and click on the release notes on the right side of the page and look at about page 22 (or search for "There is no entry for user id 0").
Does this match your nsswitch.conf situation?

Thanks,
Judy
mwarchut
Advisor

Re: drd runcmd says root doesn't have enough permissions

That appears to have fixed that issue.. Uncovering a new one. I don't see this one in the release notes..

RWOrac02\:/etc# drd runcmd update-ux -pv -s rwhpcab1:/var/11v3i/march-2010

======= 06/03/10 16:30:21 PDT BEGIN Executing Command On Inactive System Image (user=root) (jobid=RWOrac02)

* Checking for Valid Inactive System Image
* Analyzing Command To Be Run On Inactive System Image
* Locating Inactive System Image
* Preparing Inactive System Image For Command Execution
* Selected inactive system image "sysimage_001" on disk "/dev/disk/disk255".
* Accessing Inactive System Image for Command Execution
* Setting Up Environment For Command Execution
* Executing Command On Inactive System Image
/opt/drd/wrappers/start_fsdaemon[22]: start_fsdaemon: not found.
* Stopping swagentd for drd runcmd
/opt/drd/wrappers/stop_fsdaemon[22]: stop_fsdaemon: not found.
ERROR: Command executed on inactive system image returned an error
- One or more postcommands for /usr/sbin/update-ux failed.
- One or more precommands for /usr/sbin/update-ux failed. /usr/sbin/update-ux will not be executed.
- The precommand "/opt/drd/wrappers/start_fsdaemon" fails with the return code "1".
- The postcommand "/opt/drd/wrappers/stop_fsdaemon" fails with the return code "1".
* Executing Command On Inactive System Image failed with 1 error.
* Cleaning Up After Command Execution On Inactive System Image

======= 06/03/10 16:30:51 PDT END Executing Command On Inactive System Image failed with 1 error. (user=root) (jobid=RWOrac02)
Judy Wathen
Advisor
Solution

Re: drd runcmd says root doesn't have enough permissions

I'm sorry you are seeing this problem. It occurs when the release of DRD on the booted system is newer than the release on the clone. - Is that your situation?

The probem is fixed in DRD releate 3.6, which will be available on media in September and on the web this summer (proabably in July).

The problem would go away if you re-cloned, thus making the releases of DRD match, but here a quicker work-around is to copy the file /opt/drd/wrappers/common_utils to the clone as follows:

# drd mount
# cp /var/opt/drd/mnts/sysimage_001/opt/drd/wrappers/common_utils /var/opt/drd/mnts/sysimage_001/opt/drd/wrappers/common_utils.orig
# cp /opt/drd/wrappers/common_utils /var/opt/drd/mnts/sysimage_001/opt/drd/wrappers/common_utils

After doing this, you may want to go ahead and install the new DRD to the clone (using drd runmcd) to get rid of the swverify error introduced by the cp above.

Thanks,
Judy
mwarchut
Advisor

Re: drd runcmd says root doesn't have enough permissions

Excellent. Thank you for all your help. I will just make new clones with the 3.5 install and if need be do the nsswitch.conf rename.

Thanks again.

Mike