cancel
Showing results for 
Search instead for 
Did you mean: 

dtlogin failure

Gideon Magak
Occasional Visitor

dtlogin failure

Hi, I have have lots of problems logging into my Alpha 4100 server thru the console. The login doesnot succeed and fails with a dialog window with an OK button and an exclamation mark(OK!) I wonder what that means.
3 REPLIES
Alex Glennie
Honored Contributor

Re: dtlogin failure

to add some detail Gideon also reports the following : Digital unix v4.0 on alpha server 4100

the content of 'startlog' file for root:

--- Tue Mar 25 19:39:00 GMT+0300 2003
--- /usr/dt/bin/Xsession starting...
--- Xsession started by dtlogin
--- Starting the checklist setup
--- Reloading host access via dxhosts
--- sourcing //.dtprofile...
--- sourcing /etc/dt/config/Xsession.d/dtconfig...

Usage: Needs one argument

CDE configuration utility

/usr/dt/bin/Xsession -d (disable auto-start)
/usr/dt/bin/Xsession -e (enable auto-start)
/usr/dt/bin/Xsession -start (start dtlogin)
/usr/dt/bin/Xsession -kill (kill dtlogin)
/usr/dt/bin/Xsession -reset (reset dtlogin)
/usr/dt/bin/Xsession -p (printer action update)

Xlib: connection to ":0.0" refused by server
Xlib: Client is not authorized to connect to Server
Warning: cannot open display

out of interest did you find an Xconfig file on the server and if yes, was there a Dtlogin*authorise resource listed here ?

Also consider creating a file /etc/X0.hosts and add the local servers hostname here, and as with the Xconfig , you'll need to restart X/CDE for the changes to take effect.

As Gideon knows I don't have access to a tru64 box which is proving a problem so anyone who knows about CDE on tru64 please gives us a few pointers.

ps welcome to the itrc forums Gideon.






Dave Bechtold
Respected Contributor

Re: dtlogin failure

Hi Gideon,

Sorry your experiencing problems with CDE on Tru64 UNIX.

Let's see if the below information helps to resolve this. If not please post the requested information so we can further assist.

1) Under the CDE Login dialog window, can you select OPTIONS - Session - DXSession, then attempt to login? If yes, what happens?

If the above works, the problem is specific to CDE login requirements. Maybe the network is not configured, or problems in the user's .dt directory or related X Windows/CDE resource files.

If the login to DXSession works try the following:

- Rename the user accounts $HOME/.dt directory out of the way. Along with the following user's files if they exist -
$HOME/.dtprofile,
$HOME/.Xauthority, $HOME/DXsession, $HOME/.xsession, files. Just use mv on the file adding a .orig extension. Then retry the login.

- Disable CDE's dependency on the Tooltalk network service and retest. To do this edit the /etc/inetd.conf file and comment out the rpc.ttdbserverd line and restart the network; then add the following line to the user's $HOME/.dtprofile file:

DTNONETWORK=true;export DTNONETWORK

If the DXsession still fails check the following:

- Make sure the user account can login to the system via telnet or serial terminal without errors. Possible problems may exist where the user's $HOME directory file system is non-existent, or writeable; the user's login shell is having problems with sourcing .profile or .login or any associated callouts from those files.

If the above doesn't help, then provide the following information.

- Has the login to CDE ever worked? If yes, what accounts could use it ? (i.e. root)

- Does the current login problem effect all user's or only specific users?

- What was changed leading up to the problem occurring? Was the system upgraded, the network reconfigured, the system newly installed?

- What version of Tru64 UNIX V4.0 is running on the system?

Hope this helps.

Regards,
Dave Bechtold

Re: dtlogin failure

The most common problem with CDE loginproblems is that the server does not have a correct hostsfile or that reverse lookup fails. Check with command "hostname" and see if there is an entry for that name in /etc/hosts. Can you login without CDE? Coose options from loginbox and Session=Failsafe.
There must also be a entry for localhost to ip 127.0.0.1

Regards
Kjetil