cancel
Showing results for 
Search instead for 
Did you mean: 

error to use "top" command

SOLVED
Go to solution
haeman
Frequent Advisor

error to use "top" command

When I use command "top" , it pop the below message , and then exit to shell, can advise what is wrong in my system ? thx



9:53am up 25 days, 1:47, 47 users, load average: 3.15, 1.24, 1.23
410 processes: 408 sleeping, 3 running, 0 zombie, 0 stopped
CPU0 states: 25.0% user, 75.0% system, 0.0% nice, 0.0% idle
CPU1 states: 50.0% user, 50.0% system, 0.0% nice, 0.0% idle
Floating point exception
No tags yet, please

ps. I use RHEL
3 REPLIES
Steven E. Protter
Exalted Contributor
Solution

Re: error to use "top" command

Shalom,

Check the redhat site via up2date or yum for a patch.

Thats a known bug if I GUESS your update and OS correctly.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Yogeeraj_1
Honored Contributor

Re: error to use "top" command

hi,

You should have posted this in the Linux section of this forum!

Anyway, you should be able to get more information about the error by using
"strace top".

In the worst case, you may have to download a more recent version of the procps source, compile it, and see if that has the same problem.


good luck!
kind regards
yogeeraj

No person was ever honoured for what he received. Honour has been the reward for what he gave (clavin coolidge)
haeman
Frequent Advisor

Re: error to use "top" command

thx

I check that my server have below package ,
I am wonder why this package has problem ( it (procps-2.0.7-11
) repeatly pop for 6 times as below , except re-compile procps , is there any method to fix it ? thx

#rpm -qa |grep procps
procps-2.0.7-11.21AS.1
procps-2.0.7-11
procps-2.0.7-11
procps-2.0.7-11
procps-2.0.7-11
procps-2.0.7-11
procps-2.0.7-11