System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

error while creating database

gab_in
Regular Advisor

error while creating database

I am getting following error while creating database on TRU64 V5.1:

ORA-00600: internal error code, arguments: [907], [], [], [], [], [], [], []

ORA-00600: internal error code, arguments: [907], [], [], [], [], [], [], []

ORA-27120: unable to removed shared memory segment

Compaq Tru64 UNIX Error: 22: Invalid argument

After doing some research on google, it says the above error might be due to any of the following reasons:

Max No. of open files reached or
shm_max kernel parameter set too small.

Can you please help me in resolving this issue?

Thanks in advance
7 REPLIES
Vladimir Fabecic
Honored Contributor

Re: error while creating database

Max No. of open files reached or
shm_max kernel parameter set too small.

Most likely that shm_max is too small.
Post output of:
# sysconfig -q ipc
In vino veritas, in VMS cluster
gab_in
Regular Advisor

Re: error while creating database

Hi Vladimir,

Thx for the reply. Please find below the sysconfig output

# sysconfig -q ipc
ipc:
msg_max = 8192
msg_mnb = 16384
msg_mni = 64
msg_tql = 4096
shm_max = 2147483647
shm_min = 1
shm_mni = 1024
shm_seg = 512
sem_mni = 512
sem_msl = 1600
sem_opm = 400
sem_ume = 400
sem_vmx = 32767
sem_aem = 16384
sem_broadcast_wakeup = 1
max_kernel_ports = 167456
ssm_threshold = 0
ssm_enable_core_dump = 1
shm_allocate_striped = 1
shm_enable_core_dump = 1
#
Vladimir Fabecic
Honored Contributor

Re: error while creating database

Try to set shm_max to 4278190080.
Here are my "working ipc parameters:
# sysconfig -q ipc
ipc:
msg_max = 8192
msg_mnb = 16384
msg_mni = 64
msg_tql = 40
shm_max = 4278190080
shm_min = 1
shm_mni = 256
shm_seg = 128
sem_mni = 16
sem_msl = 25
sem_opm = 10
sem_ume = 10
sem_vmx = 32767
sem_aem = 16384
sem_broadcast_wakeup = 0
max_kernel_ports = 167456
ssm_threshold = 8388608
ssm_enable_core_dump = 1
shm_allocate_striped = 1
shm_enable_core_dump = 1
pshared_hash_size = 2048
#
In vino veritas, in VMS cluster
gab_in
Regular Advisor

Re: error while creating database

Pls find below the memory details, I hv 4GB total physical memory, can i change the settings as per ur settings.

# vmstat -P |grep "^Total Physical Memory"
Total Physical Memory = 4096.00 M
#

# /usr/sbin/swapon -s

Swap partition /dev/disk/dsk2b (default swap):
Allocated space: 245145 pages (1.87GB)
In-use space: 17560 pages ( 7%)
Free space: 227585 pages ( 92%)

Swap partition /dev/disk/dsk10c:
Allocated space: 523755 pages (4.00GB)
In-use space: 18467 pages ( 3%)
Free space: 505288 pages ( 96%)

Swap partition /dev/disk/dsk12c:
Allocated space: 523755 pages (4.00GB)
In-use space: 18133 pages ( 3%)
Free space: 505622 pages ( 96%)

Swap partition /dev/disk/dsk13c:
Allocated space: 523755 pages (4.00GB)
In-use space: 17697 pages ( 3%)
Free space: 506058 pages ( 96%)

Swap partition /dev/disk/dsk14c:
Allocated space: 523755 pages (4.00GB)
In-use space: 18045 pages ( 3%)
Free space: 505710 pages ( 96%)


Total swap allocation:
Allocated space: 2340165 pages (17.85GB)
Reserved space: 439481 pages ( 18%)
In-use space: 89902 pages ( 3%)
Available space: 1900684 pages ( 81%)
# #

Thanks
gab_in
Regular Advisor

Re: error while creating database

one more thing, I am using Oracle 9i
Vladimir Fabecic
Honored Contributor

Re: error while creating database

Do not worry about total amount of RAM.
Just set shm_max to 4278190080 and try to create database.
Oracle expects shm_max to be 4278190080, no matter how much RAM you have (you have enough SWAP).
In vino veritas, in VMS cluster
Vladimir Fabecic
Honored Contributor

Re: error while creating database

HU
Did you create database?
Parameters I gave you are from system running Oracle 9i.
In vino veritas, in VMS cluster