System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

eth not supporting autoneg off for 1G speed

monu_1
Regular Advisor

eth not supporting autoneg off for 1G speed

Hi all

I want autoneg off for 1G speed on eth4 interface. It's not working like below:-
ethtool version is 1-1.8-5.0704443

#ethtool -s eth4 speed 1000 duplex full autoneg off
#ethtool eth4
Settings for eth4:
Supported ports: [ TP ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Supports auto-negotiation: Yes<--se here
Advertised link modes: 1000baseT/Full
Advertised auto-negotiation: Yes
Speed: Unknown! (65535)<----see here
Duplex: Unknown! (255)<-----see here
Port: Twisted Pair
PHYAD: 0
Transceiver: internal
Auto-negotiation: on<----see here
Supports Wake-on: umbg
Wake-on: d
Current message level: 0x00000007 (7)
Link detected: no

And when I am using same configuration for eth0 interface it's working like below-

# ethtool -s eth0 speed 1000 duplex full autoneg off
#ethtool eth0
Settings for eth0:
Supported ports: [ TP MII ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Advertised auto-negotiation: No<--see here
Speed: 1000Mb/s
Duplex: Full
Port: MII
PHYAD: 12
Transceiver: internal
Auto-negotiation: off<--see here
Link detected: yes

What is the problem with eth4 interface? Why its not supporting 1G with autonegotiable off?

Please suggest!

Thanks
-Manoj


1 REPLY
Matti_Kurkela
Honored Contributor

Re: eth not supporting autoneg off for 1G speed

Autonegotiation is a mandatory part of the 1G ethernet standard 1000base-T (IEEE 802.3ab).

All standards-compliant devices that use gigabit Ethernet over a Cat5 (or Cat5e) twisted pair cabling *must* support autonegotiation on gigabit speeds. This is because on each gigabit link, one end is designated as "master" and the other is "slave".

In many gigabit Ethernet devices, the "disable autonegotiation" function is implemented in a sneaky way: it does not actually stop the device from replying to autonegotiation replies, but when autonegotiation is disabled, the device's reply will indicate that only the desired mode is supported. This allows the master/slave decision logic to work, and still fulfills the user's requirement to lock the card to a single mode.

Note that the last line of the ethtool output for the eth4 interface says:

Link detected: no

In other words, you might have a bad cable or some similar physical problem.

For more details about gigabit Ethernet autonegotiation, see here:
http://www.ethermanage.com/ethernet/pdf/dell-auto-neg.pdf

MK
MK