cancel
Showing results for 
Search instead for 
Did you mean: 

extract gives blank info

MSwift
Regular Advisor

extract gives blank info

Greetings!

Here is what i did. I needed the cpu/memory utilization for the last one week on a machine running 11.0 (Lclass). I followed this thread's (Geoff Wild's example)
http://forums11.itrc.hp.com/service/forums/questionanswer.do?threadId=1207964
my mwa status seems fine (i just stopped and started the mwa and removed the log* files). but i get an empty report in the email. Here is the report i got..

MWA Export on ACER23
| | | |System| User |SysCall|Intrpt| Pri |CSwtch| | Peak |DskSubsys|Memory|Cache |Pg Out | Swap |Memory| Network |Netwk| Netwk |
Year| Date |Time |CPU % |CPU % |CPU % | CPU % |CPU % |Queue |CPU % |Swap %|Disk %| Queue | % |Hit % | Rate |Out Rt |Queue | Pkt Rt |OutQ | Queue |

Here is the command i used

/opt/perf/bin/extract -xp -r /home/mswift/zgbltemplate -g -b 06/30/09 -e today-1 18:00 -f stdout | /bin/mailx -s 'ACER23 report' mswift2007@aol.com >/dev/null 2>&1


Would i be missing something? Please advise.

Thanks

Mike
6 REPLIES
Steven E. Protter
Exalted Contributor

Re: extract gives blank info

Shalom,

Well....one thing.

/opt/perf/bin/extract -xp -r /home/mswift/zgbltemplate -g -b 06/30/09 -e today-1 18:00 -f stdout | /bin/mailx -s 'ACER23 report' mswift2007@aol.com >/dev/null 2>&1

You are trying to send mail to aol.com

aol.com checks that the mail is from a ip address that can dns resolve. It checks that there is a valid, consistent reverse dns lookup.

I would not be surprised of aol plays games with attachments or even the mail body with their filters.

Blank mail. Hmmm.. Try this:

mailscript with and attachment.

http://www.hpux.ws/?p=7

Do your output to a file.

I'm pretty sure you are getting no output, but if you go to a file and its empty on the HP-UX system you will be sure.


SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Patrick Wallek
Honored Contributor

Re: extract gives blank info

The first thing to check is whether or not the extract command is actually generating any output.

Run the extract command itself, no e-mailing, and see what output you get. Tweak that command until you get what you want. Then add the e-mail back.
MSwift
Regular Advisor

Re: extract gives blank info

It is not a mail issue. i just did the output w/o the email part and this is what i get

MWA Export on ACER23
| | | |System| User |SysCall|Intrpt| Pri |CSwtch| | Peak |DskSubsys|Memory|Cache |Pg Out | Swap |Memory| Network |Netwk| Netwk |
Year| Date |Time |CPU % |CPU % |CPU % | CPU % |CPU % |Queue |CPU % |Swap %|Disk %| Queue | % |Hit % | Rate |Out Rt |Queue | Pkt Rt |OutQ | Queue |


so my question is why am not gettinbg any data but just the blanks?

Thanks

Mike
Vishu
Trusted Contributor

Re: extract gives blank info

Hi,

********* my mwa status seems fine (i just stopped and started the mwa and removed the log* files). but i get an empty report in the email ***********

extract - reads the contents of MWA scopeux log files or DSI log files and exports data in ASCII, BINARY, DATAFILES or WK1 (spreadsheet) format for use by other programs.
The default files to be extracted from are the raw log files in the following directories :

/var/opt/perf/datafiles/ (logglob, logappl, logproc, logdev, logtran)

You removed the log files, so extract may not be able to read the performance date from them.

Nido
Trusted Contributor

Re: extract gives blank info

Hello Mike,

Hows the log files look like under /var/opt/perf/datafiles

Do you see any logs generated after you removed the log files and restarted mwa daemons.?
#ls -l /var/opt/perf/datafiles/log*


Good Luck!!
" Let Villagers Be Happy!! "
Mel Burslan
Honored Contributor

Re: extract gives blank info

Ranju had a good point above. If you needed historical data to be interpreted and extracted, you should not have removed the measureware logs. If you really but really need them, I hope you have good backups of those files.

If you want to start your baseline now, in order to get something, you need to let mwa collect logs for a few hours, then try running extract. If your log file deletion and restart of mwa is recent, it is expected not to get any output.
________________________________
UNIX because I majored in cryptology...