System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

failed in prerequisite/file applicability check

rottereau
Advisor

failed in prerequisite/file applicability check

I try to update a tru64 5.1B to 5.1B3 bur during the check done by dupatch, the procedure is stopped because a previous patch (it seems to be sysman) abort the update.
Tru64_UNIX_V5.1B / System Administration Patches:
Patch 26079.00 - SP05 OSFSYSMAN540 (SSRT1-42U SSRT1-41U SSRT1-40U)
./usr/share/sysman/sms/objects/base.smo:
its origin can not be identified.

If you have a solution for this kind of problems, thanks to answer me.
Manuel R.
13 REPLIES
Ivan Ferreira
Honored Contributor

Re: failed in prerequisite/file applicability check

I think that a problem like this was posted before, the solution was to install PK4 first and then PK5.
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
Ivan Ferreira
Honored Contributor

Re: failed in prerequisite/file applicability check

Here is the thread:

http://forums1.itrc.hp.com/service/forums/questionanswer.do?threadId=967205
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
rottereau
Advisor

Re: failed in prerequisite/file applicability check

thanks for the link. I will try it and will tell you.
Manuel.
rottereau
Advisor

Re: failed in prerequisite/file applicability check

Oki. Patch pk4 is already fully installed but the problem is always the same.
Should i try to unistall the OFS subpatch related to sysman? and try after to install the pk5 patch?
Manuel R.
Ivan Ferreira
Honored Contributor

Re: failed in prerequisite/file applicability check

What if you first run Patch Baseline Analysis/Adjustment? Do you have the same error? Is your PK checksum correct?
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
rottereau
Advisor

Re: failed in prerequisite/file applicability check

Apparently, no baseline has been done before, for the previous kit installed. I dont know how to install later patch now.
Manuel R.
Venkatesh BL
Honored Contributor

Re: failed in prerequisite/file applicability check

Did you try using the "Baselining" option of dupatch tool?
Ivan Ferreira
Honored Contributor

Re: failed in prerequisite/file applicability check

Before Installing PK5, run Patch Baseline Analysis/Adjustment. We would like to know the results. Use dupatch option 5.
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
rottereau
Advisor

Re: failed in prerequisite/file applicability check

Here the resume of the baseline result with pk5:
* list of patches with file applicability conflicts:
-------------------------------------------------

- Tru64_UNIX_V5.1B / System Administration Patches:
Patch 26079.00 - SP05 OSFSYSMAN540 (SSRT1-42U SSRT1-41U SSRT1-40U)
- Changed files with unknown origin are:
./usr/share/sysman/sms/objects/base.smo
- Other file(s) within this patch, with their origin (identified
through checksum match) listed in terms of their translated
subset information, if any, are:
/etc/.new..doprc
Tru64_UNIX_V5.1B Patch 25079.00 ./usr/dt/appconfig/help/C/fs_df.sdl
Tru64_UNIX_V5.1B Patch 25079.00 ./usr/dt/appconfig/help/C/fs_dismount.sdl
Tru64_UNIX_V5.1B Patch 25079.00
Do you want to enable the installation of any of these patches? [y/n]: n
Phase 6 - Report Customer Specific Patches with inventory conflicts
-------------------------------------------------
The complete baseline log is in attachment
Manuel R.

Ivan Ferreira
Honored Contributor

Re: failed in prerequisite/file applicability check

Whell, I think that you can override that package because is included in PK5 (see the doc, Patch 26079.00 is included).

From the patch guide (1.6.4.1):

If all Customer-Specific patch files are overwritten by the patches noted in
Phase 5, you can safely enable dupatch to overwrite applicable missing or
unknown system files.

Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
Johan Brusche
Honored Contributor

Re: failed in prerequisite/file applicability check


You should have answered "y" at the enable question, and then the installation of PK#5 will succeed.

___ Johan./

_JB_
rottereau
Advisor

Re: failed in prerequisite/file applicability check

oki but if i answer yes, is there any problem if i install the patch without baseline adjustment (because in the other case nothing is installed to prevent conflicts i think).
Manuel
Ivan Ferreira
Honored Contributor

Re: failed in prerequisite/file applicability check

First you must answer y to baseline, then the patch will be installed. You won't be able to directly install the patch.
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?