HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
cancel
Showing results for 
Search instead for 
Did you mean: 

ftp 530 error

 
SOLVED
Go to solution
Yaroki
Super Advisor

ftp 530 error

Hi, 

 

I'm trying to ftp ftom my HP-UX B.11.11 to the Linux (RHEL6) machine.

I receives the following error:

 

# ftp -v server

Connected to server.

220 (vsFTPd 2.2.2)

Name (server:root): "I entered user name"

331 Please specify the password.

Password: "I entered the password for the above user"

530 Login incorrect

Login failed.

ftp> pwd

530 Please login with USER and PASS

 

 

ping is OK for both sides.

ssh is working for both sides.

I'v entered the /bin/bash entry -> /etc/shells of the HP-UX.

I'v entered .netrc the relevant fields.

 

Please advice.

 

Yali

5 REPLIES
Yaroki
Super Advisor

Re: ftp 530 error

BTW,

lftp command from Linux machine is working fine and connects to HP-UX.
Yaroki
Super Advisor

Re: ftp 530 error

Now I created new user and I received the following error message:
500 OOPS: cannot change directory: /home/visitor
Login failed
(visitor=user)
Matti_Kurkela
Honored Contributor

Re: ftp 530 error

Are there any FTP-related error messages in the logs of the Linux system? (Check /var/log/secure and /var/log/messages.)

 

The log messages probably include the reason why vsFTPd is rejecting the login attempt.

 

If you already have SSH working, why don't you use its scp/sftp tools for file transfer? Just set up SSH key authentication, then you can easily write scripts to move files between hosts. (If you need help in setting SSH key authentication, google for it: it has been explained many times in this forum and elsewhere.)

 

 

MK
donna hofmeister
Trusted Contributor

Re: ftp 530 error

are you sure your linux server will accept plain ftp requests?

 

most systems now will only do secure ftp (sftp)

Yaroki
Super Advisor
Solution

Re: ftp 530 error

Hello Mr. Kurkela,

 

As always you right - that was a SELinux issue. It prevents the ftp daemon access to users directories (/).

That I concluded from /var/log/secure file.

I ran:

# setsebool -P ftp_home_dir=1 

as root on the / directory and it works!!!

Great! Thanks a lot!

Yali.