cancel
Showing results for 
Search instead for 
Did you mean: 

ftp error

SOLVED
Go to solution
himacs
Super Advisor

ftp error

HI admins,

Last week i have added banner '/etc/issue' in ftpaccess file and flag -a in ftp line inetd.conf.After that application team complained
not able to login thro ftp.
First i created /etc/shells and included shells.
But no use.Then i removed -a flag from inetd.conf.Its worked.Please tell me why -a caused problem.

And i want to restrict some particular shells from using ftp.How to do that


regards
himacs
7 REPLIES
Steven E. Protter
Exalted Contributor

Re: ftp error

Shalom himacs,

I did a quick man page on ftpd and it shows that -a says to enable the use of the ftpaccess file, which is the default.

This is probably just a quirk in the implementation, because of course this is the default behavior. I guess you might consider it a bug.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
James R. Ferguson
Acclaimed Contributor
Solution

Re: ftp error

Hi:

> Please tell me why -a caused problem.

This switch enables use of the '/etc/ftpd/ftpaccess' configuration file. Do you have one? What does it contain?

> And i want to restrict some particular shells from using ftp.How to do that

Configure '/etc/shells' to only specify the shells you want to function with FTP. By default, if '/etc/shells' isn't present, you have:

/sbin/sh
/usr/bin/sh
/usr/bin/rsh
/usr/bin/ksh
/usr/bin/rksh
/usr/bin/csh
/usr/bin/keysh

Regards!

...JRF...
himacs
Super Advisor

Re: ftp error

Hi JRF , SEP

Thanx for the responses..

my ftpaccess file contains below lines..

class all real,guest,anonymous *

limit all 10 Any /etc/msgs/msg.dead

readme README* login
readme README* cwd=*

message /welcome.msg login
message .message cwd=*

compress yes all
tar yes all

log commands real
log transfers anonymous,real inbound,outbound

shutdown /etc/shutmsg

email user@hostname

banner /etc/issue


regards
himacs
himacs
Super Advisor

Re: ftp error

Hi,

Syslog shown below line while application team were trying to access ftp.
ACCESS DENIED (not in any class)

what does it mean...


regards
himacs
Hakki Aydin Ucar
Honored Contributor

Re: ftp error

Michael Steele_2
Honored Contributor

Re: ftp error

Hi

Check your /etc/ftpd/ftpaccess file for the user. If there, paste into a response.
Support Fatherhood - Stop Family Law
Raj D.
Honored Contributor

Re: ftp error

himacs,

Looks like your /etc/ftpd/ftpaccess file is having wrong entry: check the file:



- Also adding -a to inetd.conf is normal to activate use of ftpaccess file:

check:
-------------
Enabling/Disabling the ftpaccess File :


To enable the /etc/ftpd/ftpaccess file, specify the -a option for the ftp entry in the /etc/inetd.conf file. For example,

ftp stream tcp nowait root /usr/lbin/ftpd ftpd -a -l -d

To disable the /etc/ftpd/ftpaccess file, specify the -A option for the ftp entry in the /etc/inetd.conf file. For example,

ftp stream tcp nowait root /usr/lbin/ftpd ftpd -A -l -d
------------


Hth,
Raj.

" If u think u can , If u think u cannot , - You are always Right . "