cancel
Showing results for 
Search instead for 
Did you mean: 

ftp issue on server.

SOLVED
Go to solution
arun khatwani
Frequent Advisor

ftp issue on server.

There is request from client about the ftp issue,

When checked i was able to do sftp to server successfully, but ftp was not working to server,

What needs to be done to open ftp ports.

Regards,
ARun K.
7 REPLIES
Steven E. Protter
Exalted Contributor
Solution

Re: ftp issue on server.

Shalom,

Lets see if ftp is configured to run.

vi /etc/inetd.conf

netstat -an | grep ":21 "
# Checks for a listener.

Based on your results, I am thinking ftp is not running.

If you can avoid activating it you should.

If not, its probably commented out in inetd.conf

inetd -c
# Reloads.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
James R. Ferguson
Acclaimed Contributor

Re: ftp issue on server.

Hi:

It is likely that FTP has been disabled. This is a good choice when 'sftp' has been properly setup.

The first place to look is in '/etc/inetd.conf'. Make sure that the 'ftp' line isn't commented-out. It should look something like:

ftp stream tcp6 nowait root /usr/lbin/ftpd ftpd -l -a

If the line is commented-out and you truly want to enable FTP, then un-comment the line and restart the 'inetd' daemon with:

# /usr/sbin/inetd -c

Regards!

...JRF...
Lijeesh N G_1
Respected Contributor

Re: ftp issue on server.

Hi,

1) Chek /etc/inetd.conf file for the following entry,

#ftp stream tcp6 nowait root /usr/lbin/ftpd ftpd -l

If # is there, remove it for enabling the port and restart the inetd by
#inetd -c

2) Check entry in /etc/ftpd/ftpusers file for checking any restriction for users.

Regards,
LIJEESH N G
arun khatwani
Frequent Advisor

Re: ftp issue on server.

ftp line is unhashed in /etc/inetd.conf file

ftp stream tcp6 nowait root /usr/lbin/ftpd ftpd -l


then also ftp is not working,

Either -a is required after -l to use the ftp configuration file.
Lijeesh N G_1
Respected Contributor

Re: ftp issue on server.

Did you restarted inetd daemon ?

#inetd -c

arun khatwani
Frequent Advisor

Re: ftp issue on server.

how can we enable the ftp port to listen

i m not seeing ftp port number in netstat -a output.
Mel Burslan
Honored Contributor

Re: ftp issue on server.

You do not enable the ftp port to listen. You just need to restart inetd. When a communication request comes in for ftp request, inetd spawns the ftpd and the connection gets established. Otherwise there is no need for another daemon sitting and waiting around.
________________________________
UNIX because I majored in cryptology...