cancel
Showing results for 
Search instead for 
Did you mean: 

ftp

Abhirama.M.V
Occasional Advisor

ftp

Hi all,
I am not getting this problem while configuring vsftpd.can any one help me.
The error is :
500 OOPS : Cannot change directory : /home/sam.

I have user 'sam' . but i am getting access by typing 'ftp' in the place of username and password.
please solve this problem....
5 REPLIES
Kapil Jha
Honored Contributor

Re: ftp

most probably look over permissions of /home/sam
Kapil
I am in this small bowl, I wane see the real world......
Abhirama.M.V
Occasional Advisor

Re: ftp

hi kapil,
its 'drwxrwxrwx'
Ivan Ferreira
Honored Contributor

Re: ftp

777 permissions are very dangerous and should not be used unless you know what you are doing. If the sam directory has 777, then maybe the home or / is not allowing access.
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
Wilfred Chau_1
Respected Contributor

Re: ftp

try ran setenforce 0, and test.(if it is not a prod system)

if it works, check to see if ftp_home_dir is set to "on"(see the below command)? If not, set it to "on" and then turn on SELinux(setenforce 1) and then try again.


# getsebool -a |grep ftp
allow_ftpd_anon_write --> off
allow_ftpd_full_access --> off
allow_ftpd_use_cifs --> off
allow_ftpd_use_nfs --> off
ftp_home_dir --> on
ftpd_disable_trans --> off
ftpd_is_daemon --> on
httpd_enable_ftp_server --> off
tftpd_disable_trans --> off
Abhirama.M.V
Occasional Advisor

Re: ftp

hi,
i tryed getsebool -a |grep ftp
i got
# getsebool -a |grep ftp
allow_ftpd_anon_write --> off
allow_ftpd_full_access --> off
allow_ftpd_use_cifs --> off
allow_ftpd_use_nfs --> off
ftp_home_dir --> off
ftpd_disable_trans --> off
httpd_enable_ftp_server --> off

is that currect?