System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

how can I establish the single file bigger than 2Gb?

 
SOLVED
Go to solution
Frequent Advisor

how can I establish the single file bigger than 2Gb?


my ia64 machine Os is hpux11.23v2 ,but I can'nt establish the single file bigger than 2Gb?
who can tell me how to do this?
4 REPLIES 4
Frequent Advisor

Re: how can I establish the single file bigger than 2Gb?

hi,
I think it depands on the FS setings.
You should create the filesystem with "largefiles".
newfs -F ___ -o largefiles ____

Honored Contributor

Re: how can I establish the single file bigger than 2Gb?

You have to enable largefile support on the files sytem.

fsadm -F vxfs /dev/vg00/rlvol7
will show you whether largefile is enabled

fsadm -F vxfs -o largefiles /mountpoint
is the command to update it.

Also needs to change the /etc/fstab
Trusted Contributor

Re: how can I establish the single file bigger than 2Gb?

Hi,

It depends on how u have created filesystem.
The file system has to support largefiles, u
can check this as below.

1] Check filesystem type

# fstyp

eg.

#fstyp /dev/vgdata/lvol12
vxfs

This returns the filesystem type
use this to get file system details as below.

2] Get filesystem details.

# mkfs -F -m

eg.

#mkfs -F vxfs -m /dev/vgdata/lvol12
mkfs -F vxfs -o ninode=unlimited,bsize=2048,version=4,inosize=256,logsize=1024,largefiles /dev/vgdata/lvol12 21659648

# mkfs -F vxfs -m /dev/vgfa/lvol6
mkfs -F vxfs -o ninode=unlimited,bsize=1024,version=3,inosize=256,logsize=1024,nolargefiles /dev/vgfa/lvol6 4300800

If FS is created with option nolorgefiles then
to support largefiles u have to take backup of
existing FS, recreate FS with option largefiles,
mount the FS and restore data from backup

see man mkfs

-Santosh
Honored Contributor
Solution

Re: how can I establish the single file bigger than 2Gb?

Hi,

You must change your filesystem to support largefiles. First check whether you have Online JFS installed: swlist | grep -i jfs

if you have Online JFS:
# fsadm -F vxfs -o largefiles /mountpoint

if you don't have online JFS:
# umount /mountpoint
# fsadm -F vxfs -o largefiles /mountpoint

after this, change the fstab to:
/dev/vgxx/lvolxx /mountpoint vxfs rw,suid,largefiles,delaylog,datainlog 0 2


regards,
Sandy
I never think of the future. It comes soon enough.