System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

how to activate the swap space

SOLVED
Go to solution
rajesh73
Super Advisor

how to activate the swap space

server memory utilization is two high

kindly find the below output
$swapinfo -tam
Mb Mb Mb PCT START/ Mb
TYPE AVAIL USED FREE USED LIMIT RESERVE PRI NAME
dev 4096 0 4096 0% 0 - 1 /dev/vg00/lvol2
reserve - 226 -226
memory 3063 2496 567 81%
total 7159 2722 4437 38% - 0 -
$

the above output real memory only used but swap memory not used.how to enable the swap space.

5 REPLIES
rajesh73
Super Advisor

Re: how to activate the swap space

in which contione the swap space active.
Ismail Azad
Esteemed Contributor
Solution

Re: how to activate the swap space

Hi,

> in which contione the swap space active.

Ok... If you are mentioning "conditions", then I would say at minimum you will need primary swap for booting your O.S.

The working of how swap space is utilized or "paging" to be more specific, depends on certain limits within your virtual memory subsystem, as you go on talking about things like minfree, lotsfree, gpgslim, desfree, parolemem etc. of which in terms of "paging out" and "deactivation" of a process, the ones that stand out would be lotsfree and minfree for which you relate it to two important daemons vhand and swapper.


Seeing the subject of the question, there is only one thing that comes to my mind and that is if you are using 11.23 or before swapmem_on is put as 0 which restricts "pseudo swap", decreasing the total amount of "reservable swap" which might restrict a process from starting as it does not have space in swap for it to start. Consider this parameter.

Regards
Ismail Azad

Read, read and read... Then read again until you read "between the lines".....
nijokj
Trusted Contributor

Re: how to activate the swap space

please find the reference from the another system.

swapinfo -tam
Mb Mb Mb PCT START/ Mb
TYPE AVAIL USED FREE USED LIMIT RESERVE PRI NAME
dev 32768 0 32768 0% 0 - 1 /dev/vg00/lvol2
dev 20480 0 20480 0% 0 - 1 /dev/vg00/lvol9
reserve - 6582 -6582
memory 20474 4791 15683 23%
total 73722 11373 62349 15% - 0 -


swap memory will be used only when your system required.

Your swap is already activated thats why its showing in swapinfo output.otherwise it will not show.
Dennis Handly
Acclaimed Contributor

Re: how to activate the swap space

>the above output real memory only used but swap memory not used. how to enable the swap space?

>nijokj said, the kernel doesn't use your device swap if there is pseudo swap available.

>Ismail: swapmem_on is put as 0 which restricts "pseudo swap". Consider this parameter.

Since "memory" shows up, this parm is set correctly.
sunil2singh
Occasional Visitor

Re: how to activate the swap space

i am also facing the same problem

actually while running glance i am getting swap memory utilization as 93 %

Glance C.04.70.000 15:01:11 lambodar ia64 Current Avg High
-----------------------------------------------------------------------------------------------------------------------------
CPU Util S SN NU U | 25% 33% 41%
Disk Util F F | 20% 14% 31%
Mem Util S SU UB B | 99% 99% 99%
Swap Util U UR R | 93% 93% 93%


but when i run swapinfo -tam it showing following

root #/ >swapinfo -tam
Mb Mb Mb PCT START/ Mb
TYPE AVAIL USED FREE USED LIMIT RESERVE PRI NAME
dev 8192 0 8192 0% 0 - 1 /dev/vg00/lvol2
dev 8160 0 8160 0% 0 - 1 /dev/vg_sec_swap/lvol1
dev 16352 0 16352 0% 0 - 1 /dev/vg_tertiary_swap/lvol1
reserve - 32704 -32704
memory 16362 13063 3299 80%
total 49066 45767 3299 93% - 0 -