cancel
Showing results for 
Search instead for 
Did you mean: 

how to configure?

SOLVED
Go to solution
fizan
Super Advisor

how to configure?

Inactive terminal should be automatically log out after 3000 seconds (Set session idle time out limit as 3000 seconds)in ia64 hp server rx2600

9 REPLIES
Pete Randall
Outstanding Contributor
Solution

Re: how to configure?

Sunny123_1
Esteemed Contributor

Re: how to configure?

The most likely way is to set the TMOUT environment variable.


To set it for this session:

# export TMOUT=3000

To make the change permanent set it in your .profile file

Regards
Sunny
fizan
Super Advisor

Re: how to configure?

its not only for a particular user its for the all users in that box.. so how to.
Sunny123_1
Esteemed Contributor

Re: how to configure?

Hi

Set that parameter in /etc/profile and in .profile which is in the /etc/skel directory.


Regards
Sunny
Matti_Kurkela
Honored Contributor

Re: how to configure?

export TMOUT=3000

sets the value, but the user can change it if he/she wishes. If you want to force this setting for all users, you may wish to also mark it read-only so it cannot be changed once set:

typeset -r TMOUT

Adding the TMOUT setting(s) listed above to /etc/profile makes it take effect in all sessions that use /usr/bin/sh or other Bourne-style shells.

If some of your users use csh (gack!) or tcsh shells, you must also edit /etc/csh.cshrc. It is the equivalent of /etc/profile for those shells. For csh-style shells, the syntax is different and the value must be in minutes:

set autologout=50

Unfortunately, it looks like csh has no way to mark the setting read-only, so users with a csh shell will always be able to disable the auto-logout if they wish (and know how).

MK
MK
Sharma Sanjeev
Respected Contributor

Re: how to configure?

Hi

As Suggested above, Set Timeout parameter in /etc/profile ( .profile )

Regards
Sanjeev
Everything is Possible as " IMPOSSIBLE" word itself says I M POSSIBLE
Patrick Wallek
Honored Contributor

Re: how to configure?

You must keep in mind though that the session timeout will ONLY work if the user is setting at the unix prompt.

If the user is in an application, or has vi'd a file, then the user will be seen as "busy" and the timeout will not have any impact.

If the user is in some sort of application, then this will have to be done from the application side.
saravanan08
Valued Contributor

Re: how to configure?

Hi Fizan,

Add this three lines in /etc/profile

TMOUT=3000
readonly TMOUT
export TMOUT

It will work for all the users

as Patrick said it work fo application login i think..
fizan
Super Advisor

Re: how to configure?

Thanks experts for timely help.