HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
cancel
Showing results for 
Search instead for 
Did you mean: 

how to enable rlogin?

 
fizan
Super Advisor

how to enable rlogin?

how to enable rlogin for a single user?
8 REPLIES
Hakki Aydin Ucar
Honored Contributor

Re: how to enable rlogin?

As far as I know, rlogin based on host not user, so you can go to server and put your host in the .rhosts file to allow access. (without password)
Johnson Punniyalingam
Honored Contributor

Re: how to enable rlogin?

Hi Fizan,

make sure you uncomment as below service in regards to rlogin, you also enable telnet

Step (1)# more /etc/services |grep rlogin
klogin 543/tcp # Kerberos rlogin -kfall
eklogin 2105/tcp # Kerberos encrypted rlogin -kfall


Step (2)Check the below file if you have any deny for rlogin from below file

# more /var/adm/inetd.sec |grep rlogin

Step (3)
if you want to rlogin fromServer A and B

.rhosts file must create.on the both A & B

HTH,

Johnson
Problems are common to all, but attitude makes the difference
fizan
Super Advisor

Re: how to enable rlogin?

# cat /var/adm/inetd.sec
# @(#)B11.23_LRinetd.sec $Revision: 1.10.214.1 $ $Date: 96/10/08 13:20:06 $
#
#
# The lines in the file contain a service name, permission field and
# the Internet addresses or names of the hosts and/or networks
# allowed to use that service in the local machine.
# The form for each entry in this file is:
#
#
#
# For example:
#
# login allow 10.3-5 192.34.56.5 ahost anetwork
#
# The above entry allows the following hosts to attempt to access your system
# using rlogin:
# hosts in subnets 3 through 5 in network 10,
# the host with Internet Address of 192.34.56.5,
# the host by the name of "ahost",
# all the hosts in the network "anetwork"
#
# mountd deny 192.23.4.3
#
# The mountd entry denies host 192.23.4.3 access to the NFS rpc.mountd
# server.
#
# Hosts and network names must be official names, not aliases.
# See the inetd.sec(4) manual page for more information.
dtspc allow 127.0.0.1 loopback electra2

this my output and how i need to enable it i tried to login from that user using putty by selecting rlogin its not getting connected.
fizan
Super Advisor

Re: how to enable rlogin?

# cat /etc/services |grep rlogin
klogin 543/tcp # Kerberos rlogin -kfall
eklogin 2105/tcp # Kerberos encrypted rlogin -kfall

so this is as it you ve said then why its not connecting by rlogin?
OldSchool
Honored Contributor

Re: how to enable rlogin?

Perhaps because JP's post referred to the Kerberized rlogin. There are other options as well. For example see the man page for rlogind -or-

http://docs.hp.com/en/B2355-90692/rlogind.1M.html

Note that the following may need to be enabled as well:

"To start rlogind from the inetd daemon in a non-secure environment, the configuration file /etc/inetd.conf must contain an entry as follows:

login stream tcp nowait root /usr/lbin/rlogind rlogind
"

after having made changes, restart / re-read inetd.cong by issuing:

/usr/sbin/inetd -c


And for what it's worth, in "cat /etc/services |grep rlogin" you don't need the "cat". In that example is spawns unnecessary process. grep can read files all by itself, as in

grep rlogin /etc/services


As always, the actual error(s) encountered, instead of "not connecting" or "not working" could be useful
OldSchool
Honored Contributor

Re: how to enable rlogin?

and you are aware that many sites will not allow rlogin (or any of the other "R" services) as 1) they present security risks and 2) auditors generally require they be disabled.

The typical recommendation is to *disable* rloging and install / enable ssh & sshd
Johnson Punniyalingam
Honored Contributor

Re: how to enable rlogin?

Hi Fizan,

what error do you get while rlogin ?

As mentioned above earlier post by "Old School"

have you checked "inetd.conf" ?

Once done

# inetd -c

Example :-
$ grep rlogin /etc/inetd.conf
login stream tcp nowait root /usr/lbin/rlogind rlogind
# The standard remshd and rlogind do not include the Kerberized
klogin stream tcp nowait root /usr/lbin/rlogind rlogind -K

Thanks,
Johnson
Problems are common to all, but attitude makes the difference
Johnson Punniyalingam
Honored Contributor

Re: how to enable rlogin?

if still cannot :(

Pls check below link.

http://forums13.itrc.hp.com/service/forums/questionanswer.do?threadId=1324227

HTH

Johnson
Problems are common to all, but attitude makes the difference