System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Re: how to enable the crontab for user in hpux

 
SOLVED
Go to solution
Honored Contributor

Re: how to enable the crontab for user in hpux

change the following the user .profile

export EDITOR = vi

to

export EDITOR=vi

no spaces

Robert-Jan
Outstanding Contributor

Re: how to enable the crontab for user in hpux

Better yet, don't bother editing ANY profiles. Just log in as John and type

export EDITOR=vi
crontab -e

and see what happens.


Pete

Pete
Outstanding Contributor

Re: how to enable the crontab for user in hpux

And post the following, please:

ll /usr/lib/cron/cron.allow

- and/or -

ll /var/adm/cron/cron.allow


Pete

Pete
Exalted Contributor

Re: how to enable the crontab for user in hpux

Shalom,

Is the system trusted?

I remember, long ago running into a problem adding oracle to cron allow user list on a trusted system.

Had to run through a special procedure to fix it.

Though I recall betting a pretty specific error message which we are not seeing here.

As user John:

env > /tmp/john.env.txt

Take a look there.

It is possible but not advisable as root to directly edit the cron schedules in /var/spool/cron/crontabs

See what if anything is there.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Regular Advisor

Re: how to enable the crontab for user in hpux

Now it is working fine after changing as follows

export EDITOR = vi

to

export EDITOR=vi

no spaces
Honored Contributor

Re: how to enable the crontab for user in hpux

The EDITOR variable is probably being overridden in the user's profile (~john/.profile or worse, ~john/.cshrc). Type this one-line command exactly as shown (no extra semicolons or other junk):

sh EDITOR=vi crontab -e

and it will work OK even if the user is running the scummy csh shell.

NOTE: drwxrwxrwx is a severe security risk for your system. Someone tried to fix a problem by compromising the security of every cron job with 777 permissions. The correct permission is 555 owned by bin:bin.


Bill Hassell, sysadmin