System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

hpacucli: application upgrade required (Debian squeeze)

 
joliver73
Occasional Contributor

hpacucli: application upgrade required (Debian squeeze)

We have a HP ProLiant G360 D6, SmartArray P410i and Debian squeeze with an up-to-date hpacucli from http://downloads.linux.hp.com/SDR/downloads/ProLiantSupportPack, Version "HP Array Configuration Utility CLI 8.70-8.0"

 

hpacucli works fine with P410i. Today we added a SmartArray P411 and created a Raid5 using the firmware setup tool.

 

When trying to access the new P411 with hpacucli, we get this error message:

 

#hpacucli
HP Array Configuration Utility CLI 8.70-8.0
Detecting Controllers...Done.
Type "help" for a list of supported commands.
Type "exit" to close the console.

ctrl slot=1 show

Smart Array P411 in Slot 1

APPLICATION UPGRADE REQUIRED: This controller has been configured with a more
recent version of software.
To prevent data loss, configuration changes to
this controller are not allowed.
Please upgrade to the latest version to be able
to continue to configure this controller.

 

It seems I need a newer version of hpacucli, however I could not find any for Debian. I couldnt even find any reports about this error message anywhere. Do you have any suggestions how I can access the new controller with hpacucli? (sorry I can't tell you the firmware version of the P411 right now. We bought it in 04/2012).

 

Kernel: 

2.6.32-5-openvz-amd64 #1 SMP Thu Mar 22 18:35:05 UTC 2012 x86_64 GNU/Linux

 

thx

Oliver

1 REPLY
webeo
Visitor

Re: hpacucli: application upgrade required (Debian squeeze)

Same here on a HP ProLiant ML110 G7, SmartArray P212 with Ubuntu 10.04 LTS lucid. 

 

Any update here?

 

Thanks

 

EDIT:

Tested on a second HP ProLiant ML 110 G7 which is working so far. Probably a different/newer controller firmware on the other machine. Tested the latest version from HP SDR hpacucli (v.8.70-8.0).