System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

hpsmh-7.5.3-1.i386.rpm installation error on RHEL7.2

 
SOLVED
Go to solution
Syedfurquan
Trusted Contributor

hpsmh-7.5.3-1.i386.rpm installation error on RHEL7.2

Hello,

I am trying to install hpsmh-7.5.3-1.i386.rpm on my VMware VM with OS as RHEL7.2. I am trying to install hpsmh to manage hp serviceguard. While intsalling getting error as:

[root@skvlinuxhpsgtest2 tmp]# rpm -Uvh hpsmh-7.5.3-1.i386.rpm
warning: hpsmh-7.5.3-1.i386.rpm: Header V3 RSA/SHA1 Signature, key ID b1275ea3: NOKEY
Preparing... ################################# [100%]
Detected Red Hat Enterprise Linux AS/ES/WS/SERVER 7
Creating hpsmh user and group...
Updating / installing...
1:hpsmh-7.5.3-1 ################################# [100%]

**********************************************************
* System Management Homepage installed successfully with *
* default configuration values. To change the default *
* configuration values, type the following command at *
* the root prompt: *
* *
* /opt/hp/hpsmh/sbin/smhconfig *
* *
**********************************************************


hpsmhd already stopped
Starting hpsmhd: /usr/bin/nohup: redirecting stderr to stdout
/usr/bin/nohup: failed to run command â/opt/hp/hpsmh/sbin/smhMonitorâ: No such file or directory
/bin/bash: /opt/hp/hpsmh/sbin/smhstart: /lib/ld-linux.so.2: bad ELF interpreter: No such file or directory
[FAILED]

Getting same error on both VM with RHEL7.2.

Thanks,

Regards,
Syed
8 REPLIES
simplylinuxfaq
Frequent Advisor

Re: hpsmh-7.5.3-1.i386.rpm installation error on RHEL7.2

This library file belongs to glibc, check if the file is missing and install it. If the package is already found, then you may extract the missing file and place it under /lib directory. 

[root@ansible-host lib64]# rpm -qf /lib/ld-linux.so.2
glibc-2.12-1.192.el6.i68

 

Thanks,
SimplyLinuxFAQ
Syedfurquan
Trusted Contributor

Re: hpsmh-7.5.3-1.i386.rpm installation error on RHEL7.2

Hello,

Thank you for your reply. I can see the glibc installed as below:

[root@skvlinuxhpsgtest1 tmp]# rpm -qf /lib/ld-linux.so.2
glibc-2.17-105.el7.i686

Tried reinstalling/upgrading hpspmh gives the same error:

hpsmhd already stopped
Starting hpsmhd: /usr/bin/nohup: redirecting stderr to stdout
/opt/hp/hpsmh/sbin/smhstart: error while loading shared libraries: libpam.so.0: cannot open shared object file: No such file or directory
[FAILED]

Thanks,

Regards,
Syed
simplylinuxfaq
Frequent Advisor

Re: hpsmh-7.5.3-1.i386.rpm installation error on RHEL7.2

This library is from pam-devel package as you can see here, so install the required package, you may need to install i686 version of the package.

[root@ansible-host lib64]# find / -iname libpam.so 2>/dev/null
/usr/lib64/libpam.so
[root@ansible-host lib64]# rpm -qf /usr/lib64/libpam.so
pam-devel-1.1.1-22.el6.x86_64

 

Thanks,
SimplyLinuxFAQ
Syedfurquan
Trusted Contributor

Re: hpsmh-7.5.3-1.i386.rpm installation error on RHEL7.2

Tried installing pam-devel package but installing of hpsmh still failed with same error.

[root@skvlinuxhpsgtest1 tmp]# find / -iname libpam.so 2>/dev/null
/usr/lib/libpam.so
/usr/lib64/libpam.so
[root@skvlinuxhpsgtest1 tmp]# rpm -qf /usr/lib64/libpam.so
pam-devel-1.1.8-12.el7_1.1.x86_64
[root@skvlinuxhpsgtest1 tmp]# rpm -qf /usr/lib/libpam.so
pam-devel-1.1.8-12.el7_1.1.i686

Thanks,

Regards,
Syed
simplylinuxfaq
Frequent Advisor

Re: hpsmh-7.5.3-1.i386.rpm installation error on RHEL7.2

Try updating library link files by running the command "ldconfig" ...after that install the package that should go...

Thanks,
SimplyLinuxFAQ
Syedfurquan
Trusted Contributor

Re: hpsmh-7.5.3-1.i386.rpm installation error on RHEL7.2

unfortunately it doesn't start still.

[root@skvlinuxhpsgtest1 tmp]# ldconfig
[root@skvlinuxhpsgtest1 tmp]#
[root@skvlinuxhpsgtest1 tmp]# rpm -ivh hpsmh-7.5.3-1.i386.rpm
warning: hpsmh-7.5.3-1.i386.rpm: Header V3 RSA/SHA1 Signature, key ID b1275ea3: NOKEY
Preparing... ################################# [100%]
Detected Red Hat Enterprise Linux AS/ES/WS/SERVER 7
Creating hpsmh user and group...
Updating / installing...
1:hpsmh-7.5.3-1 ################################# [100%]

**********************************************************
* System Management Homepage installed successfully with *
* default configuration values. To change the default *
* configuration values, type the following command at *
* the root prompt: *
* *
* /opt/hp/hpsmh/sbin/smhconfig *
* *
**********************************************************


hpsmhd already stopped
Starting hpsmhd: /usr/bin/nohup: redirecting stderr to stdout
/opt/hp/hpsmh/sbin/smhstart: error while loading shared libraries: libcurl.so.3: cannot open shared object file: No such file or directory
[FAILED]

Regards,
Syed
simplylinuxfaq
Frequent Advisor

Re: hpsmh-7.5.3-1.i386.rpm installation error on RHEL7.2

I'd say you may need to look at the pre-requisites published at HP page for installing SMH and make sure all those needed library and corresponding packages are there in the system..

[root@ansible-host lib64]# yum provides */*libcurl.so
libcurl-devel-7.19.7-52.el6.i686 : Files needed for building applications with libcurl
Repo        : server
Matched from:
Filename    : /usr/lib/libcurl.so



libcurl-devel-7.19.7-52.el6.x86_64 : Files needed for building applications with libcurl
Repo        : server
Matched from:
Filename    : /usr/lib64/libcurl.so

This libcurl.so library file is part of libcurl-devel package.. Like-wise, make sure all required (pre-requisites) packages are present in the system and then run "ldconfig", after which you should be successfull.

Thanks,
SimplyLinuxFAQ
Syedfurquan
Trusted Contributor
Solution

Re: hpsmh-7.5.3-1.i386.rpm installation error on RHEL7.2

Thanks for all your help.

Tried installing hpsmh using SPP image and all went smoothly. HPSMH installed and running perfectly.

Thanks & Regards,

Syed

Regards,
Syed