HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

hpuxwsApache B.2.0.50.01 Web based server

 
SOLVED
Go to solution
TechC
Regular Advisor

hpuxwsApache B.2.0.50.01 Web based server

Hello,
I am trying to install Red Hat DS on my 11iV1 PA-RISC station. One of the prerequisites is
hpuxwsApache B.2.0.50.01 Web based server.

I cannot find this depot on the software depot page. I downloaded a depot from the software depot but after it installs it is listed as.
A.2.0.58.00 HP-UX Apache-based Web Server

What is the difference between software starting with A. as opposed to Software bundles that
start with B.

The RHDS instance is failing and the instructions state that HP suggests using B.2.0.50.01 but I am unable to find it. It is failing on the Admin Server portion which utilizes Apache so i am guessing I may have the wrong Apache installed.

Thank you
James









Thank you
James
9 REPLIES
Shinji Teragaito_1
Respected Contributor
Solution

Re: hpuxwsApache B.2.0.50.01 Web based server

Hi James,

Suppose you want to use RHDS 8.0. If my assumption is wrong, please
correct me.

RHDS 8.0 (RedHatDirSvr.ADMSVR-RUN fileset) requires
hpuxwsAPACHE.APACHE >= A.2.0.50. So your Apache A.2.0.58 fills this
requirement.

Did you see an error shown below when setup-ds-admin.pl starts admin
server ?

/usr/lib/dld.sl: Unresolved symbol: PR_GetLibraryFilePathname (code) from
/opt/dirsrv/lib/modules/32bit/libssl3.sl

If so, please try out the instruction for "NSPR Compatibility
Problem on HP-UX 11i v1 Systems" in /opt/dirsrv/README.hp or

* RHDS 8.0 Release Notes
http://docs.hp.com/en/J4258-90068/ch02s01.html#v1036413


Here're some references for you:

If you can upgrade your Apache, you should consider the installation
of the latest Apache 2.0.59.07.03 which is downloadable from the
following web page:

http://h20392.www2.hp.com/portal/swdepot/displayProductInfo.do?productNumber=HPUXWSATW222

The depot version name for Apache 2.0.58.* started from "A" on
11.11. Apache 2.0.59.* starts from "B" on 11.11.
On the other hand, Apache for 11.23/11.31 PA/IPF starts from "B"
regardless of 2.0.58.* or later.

Hope this helps you,

Shinji
TechC
Regular Advisor

Re: hpuxwsApache B.2.0.50.01 Web based server

Shinji,
Bingo, as soon as I followed the NSPR instructions as you mentioned the setup script completed and the Admin server started right up. I am very grateful..thank you.
I did not see any mention of the README file on the installation instructions page. I must have missed it.

Thanks again,
James

TechC
Regular Advisor

Re: hpuxwsApache B.2.0.50.01 Web based server

Hello all,
Well on my test box the Install went great. However now when I run the setup script on the production box it is failing at a point. When I look in the syslog file I see these error messages which I believe are supposed to be suppressed by PHSS_30966 that is actually superceded by PHSS_38154 which I have installed. On the test box it is fine, on the production box I get this. Any ideas? Are these accociated with openssl-SHLIBS? What is weird is if i run swlist -v | grep openssl-SHLIBS it does not show on the box that is not working and it does show on the box that is working.. I installed the same version of SSL which is OpenSSL A.00.09.07m.041. Any ideas?

Thanks
James

Here is the error messages.

Feb 13 13:46:29 HOST syslog: unable to dlopen /opt/dirsrv/lib/sasl2/libanonymous.sl.2: Unsatisfied code symbol 'getaddrinfo' in load module '/opt/dirsrv/lib/sasl2/libanonymous.sl.2'.

Feb 13 13:46:29 HOST syslog: unable to dlopen /opt/dirsrv/lib/sasl2/libcrammd5.sl.2: Unsatisfied code symbol 'getaddrinfo' in load module '/opt/dirsrv/lib/sasl2/libcrammd5.sl.2'.

Feb 13 13:46:29 HOST syslog: unable to dlopen /opt/dirsrv/lib/sasl2/libdigestmd5.sl.2: Unsatisfied code symbol 'getaddrinfo' in load module '/opt/dirsrv/lib/sasl2/libdigestmd5.sl.2'.

Feb 13 13:46:29 HOST syslog: unable to dlopen /opt/dirsrv/lib/sasl2/libgssapiv2.sl.2: Unable to find library 'libgssapi_krb5.sl'.

Feb 13 13:46:29 HOST syslog: unable to dlopen /opt/dirsrv/lib/sasl2/libplain.sl.2: Unsatisfied code symbol 'getaddrinfo' in load module '/opt/dirsrv/lib/sasl2/libplain.sl.2'.

Feb 13 13:46:29 HOST syslog: unable to dlopen /opt/dirsrv/lib/sasl2/libsasldb.sl.2: Unsatisfied code symbol 'getaddrinfo' in load module '/opt/dirsrv/lib/sasl2/libsasldb.sl.2'.

TechC
Regular Advisor

Re: hpuxwsApache B.2.0.50.01 Web based server

I am running the setup-ds-admin.pl script and getting the following errors..

[Setup] Info Registering admin server with the configuration directory server . . .
[Setup] Info Updating adm.conf with information from configuration directory server . . .
[Setup] Info Updating the configuration for the httpd engine . . .
[Setup] Info Starting admin server . . .
[Setup] Info output: /usr/lib/dld.sl: Unresolved symbol: getaddrinfo (code) from /opt/dirsrv/lib/module
s/32bit/lib/libsasl2.sl.2
[Setup] Info output: /usr/lib/dld.sl: Unresolved symbol: freeaddrinfo (code) from /opt/dirsrv/lib/modul
es/32bit/lib/libsasl2.sl.2
[Setup] Info output: Syntax error on line 146 of /etc/opt/dirsrv/admin-serv/httpd.conf:
[Setup] Info output: Cannot load /opt/dirsrv/lib/modules/32bit/mod_admserv.sl into server: Unresolved ex
ternal
[Setup] Fatal Could not reconfigure the admin server.
[Setup] Fatal Exiting . . .
+
+_
I then run ldd mod_admsrv.sl and get this output..
+
+
ldd /opt/dirsrv/lib/modules/32bit/mod_admserv.sl
/usr/lib/libc.2 => /usr/lib/libc.2
/usr/lib/libdld.2 => /usr/lib/libdld.2
/usr/lib/libc.2 => /usr/lib/libc.2
/opt/dirsrv/lib/modules/32bit/lib/libsasl2.sl.2 => /opt/dirsrv/lib/modules/32bit/lib/libsasl2.sl.2
/usr/lib/libc.2 => /usr/lib/libc.2
/usr/lib/dld.sl: Can't find path for shared library: libplc4.sl
/usr/lib/dld.sl: No such file or directory

Re: hpuxwsApache B.2.0.50.01 Web based server

>are supposed to be suppressed by PHSS_38154 which I have installed.

I don't see how a dld patch will do that? dld.sl is what detects the error.
You need a newer libc patch that adds getaddrinfo & freeaddrinfo.

TechC
Regular Advisor

Re: hpuxwsApache B.2.0.50.01 Web based server

Dennis Thanks, I am gonna try and locate that patch and install it. I will report back shortly.

Thanks again
TechC
Regular Advisor

Re: hpuxwsApache B.2.0.50.01 Web based server

Dennis, hopefully yo uare still out there.
I found this libc cumulative patch.
PHCO_35743.
Is this the correct patch?
I am running 11iv1

Thanks again

Re: hpuxwsApache B.2.0.50.01 Web based server

>I found this libc cumulative patch, PHCO_35743.

Yes, that is the recommended one.
TechC
Regular Advisor

Re: hpuxwsApache B.2.0.50.01 Web based server

Thank you for the heads up Dennis. The libc application patch did the trick.
Appreciate it.