cancel
Showing results for 
Search instead for 
Did you mean: 

i can't install patches.

SOLVED
Go to solution
Mousa55
Super Advisor

i can't install patches.

Hi All,

i can't install this three patches "PHSS_36086, PHSS_36087,PHSS_36088". although i installed the HP C++ compiler and i have the license also.
but when i tried to install the 3 patches this error appeared in a log file.

======= 01/07/09 10:33:53 WAT BEGIN install AGENT SESSION (pid=6868)
(jobid=ruxapp02-0282)

* Agent session started for user "root@ruxapp02.sp.local".
(pid=6868)

* Beginning Analysis Phase.
* Source:
ruxapp02.sp.local:/tmp/patch/PHSS_36088.depot
* Target: ruxapp02:/
* Target logfile: ruxapp02:/var/adm/sw/swagent.log
* Reading source for product information.
* Reading source for file information.
NOTE: The patch fileset "PHSS_36088.LANG-AUX,r=1.0" may only be
installed upon a previously installed base fileset. The
specification for this base fileset is
"Auxiliary-Opt.LANG-AUX,fr=B.11.11.16,v=HP". Since there is
no fileset on the target or selected from the source which
matches this specification, fileset
"PHSS_36088.LANG-AUX,r=1.0" will be excluded.
* Executing preDSA command.

* Summary of Analysis Phase:
* 1 of 1 filesets will be Skipped.
* The Analysis Phase succeeded.

all patch the same.

how to solve this problem becuase i need this patches.

thanks and best regards
10 REPLIES
Delcho Tuhchiev
Frequent Advisor
Solution

Re: i can't install patches.

Hi,

The solution is writen in the log You've already posted:

NOTE: The patch fileset "PHSS_36088.LANG-AUX,r=1.0" may only be
installed upon a previously installed base fileset. The
specification for this base fileset is
"Auxiliary-Opt.LANG-AUX,fr=B.11.11.16,v=HP". Since there is
no fileset on the target or selected from the source which
matches this specification, fileset.

In few words ou need to install Auxiliary-Opt.LANG-AUX,fr=B.11.11.16 because the patch you've try to install is for this product
Mousa55
Super Advisor

Re: i can't install patches.

Hi All,

from where i can download this product
Auxiliary-Opt.LANG-AUX,fr=B.11.11.16

thanks
Delcho Tuhchiev
Frequent Advisor

Re: i can't install patches.

Hi,

I think that this fileset is a part of HP C/aC++ Developer's Bundle for Evaluation. You can find it on this address:

http://software.hp.com/portal/swdepot/displayProductInfo.do?productNumber=B9007AAEVAL
Avinash20
Honored Contributor

Re: i can't install patches.

Hi,

If you have installed the licensed aC++ Developer bundle, then the product will automatically be installed."Auxiliary-Opt"

Meanwhile have the patch PHSS_36087,PHSS_36087 got installed

The above two patches depends only on aC++ product and not on "Auxiliary-Opt"

If you like to install PHSS_36088, then you need to have any of the following filesets

Auxiliary-Opt.LANG-AUX,fr=B.11.11.16,fa=HP-UX_B.11.00_32/64,v=HP
Auxiliary-Opt.LANG-AUX,fr=B.11.11.14,fa=HP-UX_B.11.00_32/64,v=HP
Auxiliary-Opt.LANG-AUX,fr=B.11.11.12,fa=HP-UX_B.11.00_32/64,v=HP
Auxiliary-Opt.LANG-AUX,fr=B.11.11.10,fa=HP-UX_B.11.00_32/64,v=HP


You could check the same with

# swlist -l fileset | grep Auxiliary-Opt
"Light travels faster than sound. That's why some people appear bright until you hear them speak."
Duncan Edmonstone
Honored Contributor

Re: i can't install patches.

Let me hazard a guess at what's going on here...

a) You are trying to install Oracle
b) the Oracle installer told you you needed these patches
c) When you tried to install them it failed as you don't have the C or C++ compiler installed
d) So you installed some version of C++ (an older version I suspect as it must date to before the C and C++ compilers were wrapped up into a single bundle)
e) Now some of the patches will install, but not the ones for the C compiler (not surprising as you haven't installed it)

Assuming my guess is right, the question is:

"Do you need a C/C++ Compiler? Are you planning to do C/C++ development on this system with/without Oracle Pro*C or Pro*C++"

If the answer to that is "no" then you don't need to install the compilers or the patches and can ignore the warnings from the Oracle installer.

HTH

Duncan

HTH

Duncan
Mousa55
Super Advisor

Re: i can't install patches.

Hi All,

i found this filesets
swlist -l fileset | grep Auxiliary-Opt
# Auxiliary-Opt B.11.11.18.EVAL Auxiliary Optimizer for HP Languages.
Auxiliary-Opt.LANG-AUX B.11.11.18.EVAL Advanced Optimization Tools
Auxiliary-Opt.LANG-STARTUP B.11.11.18.EVAL Family of Startup crt0.o files

this enough or no.

thanks
Avinash20
Honored Contributor

Re: i can't install patches.

Hi,

You need not install the patches, since these patches apply for licensed version

You are having evaluation version installed, for which patches are not required
"Light travels faster than sound. That's why some people appear bright until you hear them speak."
Mousa55
Super Advisor

Re: i can't install patches.

Hi All,

you mean this 3 patches are not installed on evaluation version.
i bought 4 license but i don't receive the CD's, therefore i still using the EVL version.

how i can install the non-evaluation version form hp site by using the hp order NO or identifier customer.

thanks
Avinash20
Honored Contributor

Re: i can't install patches.

http://h20293.www2.hp.com/ecommerce/efulfillment/downloadpage.do
"Light travels faster than sound. That's why some people appear bright until you hear them speak."
Dennis Handly
Acclaimed Contributor

Re: i can't install patches.

>I can't install this three patches PHSS_36086, PHSS_36087, PHSS_36088.

I have already told you that you can't install these patches in your other thread. Nothing has changed:
http://forums.itrc.hp.com/service/forums/questionanswer.do?threadId=1300041

>because I need this patches.

As mentioned by Duncan, you do not need these patches just because Oracle suggested that, you only need them for development and if you had those obsolete compiler versions.

>from where I can download this product

You must purchase the product and if you do, you still can't install those obsolete patches.

>I found this filesets
># Auxiliary-Opt B.11.11.18.EVAL Auxiliary Optimizer

These can NOT be patched.

>I bought 4 license but I don't receive the CDs

If you have a license and a support contract, you can go to the SUM web page (see to the left) and download a copy. You will have to remove your EVAL compiler.

And as I mentioned above, you can't use those obsolete patches on your newer compiler.

>Duncan: d) So you installed some version of C++ (an older version I suspect as it must date to before the C and C++ compilers were wrapped up into a single bundle)

No, the EVAL compiler is the very latest. Also, there has been no evidence for you to suspect there were two bundles.

>e) Now some of the patches will install

No, no compiler patches can be installed.

>"Do you need a C/C++ Compiler? Are you planning to do C/C++ development on this system with/without Oracle Pro*C or Pro*C++"

Right.