System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

i cannot mount filesystem on hpux

SOLVED
Go to solution
Zigmah
Occasional Contributor

i cannot mount filesystem on hpux

Hi !

Please help . I cant mount filesystem /rac-quorum2 .  I did all these commands and i didnt have no result. 

 

pvcreate -f /dev/rdisk/disk645
lvmadm -l
diskinfo /dev/rdisk/disk645
mkdir /dev/vgquorum2
mknod /dev/vgquorum2/group c 64 0x400000
vgcreate -s 16 vgquorum2 /dev/disk/disk645

***
Volume group "/dev/vgquorum2" has been successfully created.
Volume Group configuration for /dev/vgquorum2 has been saved in /etc/lvmconf/vgquorum2.conf
***

mkdir /rac-quorum2

lvcreate -L 5104 -n lvquorum2 /dev/vgquorum2
***
Logical volume "/dev/vgquorum2/lvquorum2" has been successfully created with
character device "/dev/vgquorum2/rlvquorum2".
Logical volume "/dev/vgquorum2/lvquorum2" has been successfully extended.
Volume Group configuration for /dev/vgquorum2 has been saved in /etc/lvmconf/vgquorum2.conf
***
mkfs -F vxfs -o largefiles /dev/vgquorum2/rlvquorum2

         *****there is no result message here and finally....********

mount -F vxfs -o largefiles /dev/vgquorum2/lvquorum2 /rac-quorum2
UX:vxfs mount: ERROR: V-3-20012: not a valid vxfs file system
UX:vxfs mount: ERROR: V-3-24996: Unable to get disk layout version

 

 

Regards

 

Alonso Paucar

4 REPLIES
Patrick Wallek
Honored Contributor

Re: i cannot mount filesystem on hpux

It looks like the 'mkfs' did not actually create a file system on the LV.

 

Try newfs instead of mkfs.

 

# newfs -F vxfs -o largefiles /dev/vgquorum2/rlvquorum2

 

Once that is done, try mounting the LV.

srayfay
Valued Contributor

Re: i cannot mount filesystem on hpux

Hello,

 

if you are using hpux 11.31, no need to specify largefiles,

I suggest you to add option "-b 8192" to your command newfs

Regards
rkjha_hp
Advisor

Re: i cannot mount filesystem on hpux

After lvcreate try below commands, it will work..

 

newfs -F vxfs  /dev/vgquorum2/rlvquorum2

 

mount  /dev/vgquorum2/lvquorum2 /rac-quorum2

 

rgds

Zigmah
Occasional Contributor
Solution

Re: i cannot mount filesystem on hpux

Hi,

 

Thanks a lot Patrick Wallek , srayfay and rkjha_hp for your help. I found the solution , here the details.

 

***********************************************************************************

# mount -F vxfs /dev/vg00/usr_sap_prd /test1
UX:vxfs mount: ERROR: V-3-20012: not a valid vxfs file system
UX:vxfs mount: ERROR: V-3-24996: Unable to get disk layout version


Here, when running the newfs command, it is not actually creating the filesystem.
It is same with the mkfs command as well.

Execute this

#ls -l /sbin
lr-xr-xr-x 1 bin bin   16   Jul 9 13:14 extendfs -> /sbin/fs_wrapper
-r-xr-xr-x 1 bin bin   0     Jul 21 16:41 fs_wrapper
lr-xr-xr-x 1 bin bin   16   Jul 9 13:14 fsck -> /sbin/fs_wrapper
lr-xr-xr-x 1 bin bin   16   Jul 9 13:14 fsdb -> /sbin/fs_wrapper
lr-xr-xr-x 1 bin bin   16   Jul 9 13:14 mkfs -> /sbin/fs_wrapper
lr-xr-xr-x 1 bin bin   16   Jul 9 13:14 newfs -> /sbin/fs_wrapper


The mkfs/newfs/extendfs/fsck/fsdb files are a soft link to /sbin/fs_wrapper and its size is 0 bytes.
Running swverify \* also returned an error about this /sbin/fs_wrapper file and from which fileset/patch this file was installed.

ERROR: File "/sbin/fs_wrapper" should have mtime "1115195874" but the
actual mtime is "1248174665".
ERROR: File "/sbin/fs_wrapper" should have size "647260" bytes but
the actual size is "0" bytes.

ERROR: Fileset "OS-Core.UX2-CORE,l=/,r=B.11.23" had file errors.

 

Solution
We need to restore the /sbin/fs_wrapper file for newfs /mkfs to work correctly. This can be done using the following methods:
• If the other system has identical operating system/patches, then we can copy the file from the other system.

 

***********************************************************************************

 

I just copy the file fs_wrapper from another same server with same patches and thas all. Then i can create filesystems with the command mkfs.

 

Thanks/Regards

 

Alonso Paucar