HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

inetd failed after system reboot

 
cedrichiu
Frequent Advisor

inetd failed after system reboot

hi,

Anyone could advise me at what circumstances whereby inetd failed to be running after system reboot. At any time, manual intervention like "/usr/sbin/inetd start" got to be performed.

And because of such, my system is won't be able to join part of cluster members.

Regards,
7 REPLIES
Turgay Cavdar
Honored Contributor

Re: inetd failed after system reboot

What is the error message?
Did you check /etc/rc.config.d/netdaemons? INETD value should be 1.

Re: inetd failed after system reboot

1. Look into /var/adm/syslog/syslog.log and see if you have any inetd messages in there that might give you a clue.

2. Check what inetd settings are present in /etc/rc.config.d with the following command:

grep -i inetd /etc/rc.config.d/*

3. Consider starting inted with logging enabled to see if you can spot the issue by setting

INETD_ARGS="-l"

in the file /etc/rc.config.d/netdaemons

HTH

Duncan

HTH

Duncan
cedrichiu
Frequent Advisor

Re: inetd failed after system reboot

hi there,

psa1a:/root# grep -i inetd /etc/rc.config.d/*
/etc/rc.config.d/netdaemons:# inetd configuration. See inetd(1m) #
/etc/rc.config.d/netdaemons:# NOTE: inetd is always started as part of the boot up process.
/etc/rc.config.d/netdaemons:# INETD_ARGS: The command line arguments to be used when
/etc/rc.config.d/netdaemons:# starting inetd. ("-l" is the only option
/etc/rc.config.d/netdaemons:export INETD_ARGS=-1
/etc/rc.config.d/nfsconf:# 0 if /etc/inetd.conf has an entry for mountd.
/etc/rc.config.d/nfsconf:# however, it can be started from either nfs.server or inetd, and

There was no error indication shows on syslog. I don't quite sure why. And since "INETD_ARGS=-1" should able to tell why, unfortunately it wasn't. Maybe i'm wrong.


At last, found out /usr/sbin/inetd wasn't running during the last occurrence.
Turgay Cavdar
Honored Contributor

Re: inetd failed after system reboot

In /etc/rc.config.d/netdaemons there are missing INETD and wrong INETD_ARGS value. It should be like this:
export INETD=1
export INETD_ARGS="-l"

Re: inetd failed after system reboot

Well if this is a cut/paste it looks like you have

INETD_ARGS=-1

i.e. "hyphen one"

when it should be

INETD_ARGS=-l

i.e. "hyphen lower case L"

and as tugay says, you also need to have:

INETD=1

(in this case this is a 1 rather than a lower case LK)

HTH

Duncan


HTH

Duncan
cedrichiu
Frequent Advisor

Re: inetd failed after system reboot

what are difference between ?

export INETD_ARGS=1
export INETD_ARGS=-1
export INETD_ARGS=

I noticed the default comment pertaining to such right there is..

# NOTE: inetd is always started as part of the boot up process.
#
# INETD_ARGS: The command line arguments to be used when
# starting inetd. ("-l" is the only option
# available at startup.)

#

Is it always should be equal to 1 or left blank ?

Re: inetd failed after system reboot

>what are difference between ?
>
>export INETD_ARGS=1
>export INETD_ARGS=-1
>export INETD_ARGS=

The first 2 are INCORRECT - as I said they are specifying "one" and "hyphen one" and neither of these are valid for INETD_ARGS - this is a mis-reading or typo by someone - you should either have INETD_ARGS set to "" or to "-l" (that's "hyphen lower case L").

And as we already said, you also need the parameter INETD set to 1 (in this case that *is* a one) in the netdaemons file.

HTH

Duncan

HTH

Duncan