System Administration
Showing results for 
Search instead for 
Did you mean: 

insf -e hangs (HP-UX 11.11i v1)

Alistair MacPherson
Occasional Contributor

insf -e hangs (HP-UX 11.11i v1)

We have moved our Primary SAN switch and it the process we changed the ports used in the SAN which has changed hardware paths. We overcame this by running 'vgscan -a' to remove the orignal alternate paths and replace them with the new paths. This has worked well on all our servers except one. When running 'insf -e' to install the special device files for the new paths, the 'insf -e' just runs up until the stape devices and hangs. We are unable to kill the process. If we run an ioscan after the insf command, it hangs too and cannot kill it. (but it runs fine prior to the insf) The ioscan does not display any output up to when hanging.

We have no stape devices attached to this server and I have used rmsf to delete all stape devices under /dev.

Still insf hangs during the stapes. I have also tried 'inst -C disk' to just try load the special devices for the disks without hitting the stape devices, but the command ends without having created any files.

Assistance would be appreciated.
Michael Steele_2
Honored Contributor

Re: insf -e hangs (HP-UX 11.11i v1)


Seen this before and also with tape devices. Verify connectivity or lack of connectivity to your tape devices.

runutil logtool

Should specifically name the problem device. It will have the highest integer number.
Support Fatherhood - Stop Family Law